1147 Heaps (30 分)

37 篇文章 0 订阅
该博客主要介绍了一种特殊的数据结构——堆,特别是二叉堆的概念,并提供了一个C++程序来判断给定的完全二叉树是否为最大堆或最小堆,并输出其后序遍历序列。程序首先通过比较根节点与第一个子节点确定堆类型,然后遍历树的上半部分验证堆性质。对于每个测试用例,程序会输出堆类型和后序遍历序列。
摘要由CSDN通过智能技术生成

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

首先根据v[0]和v[1]的大小关系判断是大顶堆还是小顶堆,然后遍历v[0]到v[(n - 2) / 2]判断这些节点与他们的子节点是否满足相应的大小关系,如果不满足flag变为0,然后根据后序遍历递归算法输出。

#include<bits/stdc++.h>
using namespace std;
int m, n;
vector<int> v; 
void PostOrder(int index) {
	if (index >= n) return;
	PostOrder(index * 2 + 1);
	PostOrder(index * 2 + 2);
	printf("%d%s", v[index], index == 0 ? "\n" : " ");
}
int main() {
	scanf("%d %d", &m, &n);
	v.resize(n);
	for (int i = 0; i < m; i++) {
		int flag;
		for (int j = 0; j < n; j++) {
			scanf("%d", &v[j]);
		}
		flag = v[0] < v[1] ? -1 : 1;
		for (int j = 0; j <= (n - 2) / 2; j++) {
			int Left = j * 2 + 1, Right = j * 2 + 2;   //左节点是可以保证的,右节点不一定存在要先判断是否小于n
			if (flag == 1 && (v[Left] > v[j] || (Right < n && v[Right] > v[j]))) flag = 0;
			if (flag == -1 && (v[Left] < v[j] || (Right < n && v[Right] < v[j]))) flag = 0;	
		} 
		if (flag == 1) printf("Max Heap\n");
		else if (flag == -1) printf("Min Heap\n");
		else printf("Not Heap\n");
		PostOrder(0);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值