2020PAT甲级秋季7-2 How Many Ways to Buy a Piece of Land (25分)

7-2How Many Ways to Buy a Piece of Land(25分)

The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: N (≤10​4​​ ), the number of pieces of the land (hence the land pieces are numbered from 1 to N in order), and M (≤10​9​​ ), the amount of money that your customer has.

Then in the next line, N positive integers are given, where the i-th one is the price of the i-th piece of the land.

It is guaranteed that the total price of the land is no more than 10​9
​​ .

Output Specification:

For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.

Sample Input:

5 85
38 42 15 24 9

Sample Output:

11

Hint:

The 11 different ways are:

38
42
15
24
9
38 42
42 15
42 15 24
15 24
15 24 9
24 9

#include<bits/stdc++.h>
using namespace std;
int N, Price, sum = 0;
vector<int> v;
int main() {
	scanf("%d %d", &N, &Price);
	v.resize(N);
	for (int i = 0; i < N; i++) {
		scanf("%d", &v[i]);
		if (v[i] <= Price) sum++;
	}
	for (int i = 0; i < N - 1; i++) {
		int a = v[i];
		for (int j = 1; j <= N - 1 - i; j++) {
			if (a >= Price) break;
			a += v[j + i];
			if (a <= Price) sum++;
		}
	}
	cout << sum;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值