HDU 2473 Junk-Mail Filter 【并查集+设立虚父节点(马甲)】

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=2473


原题:

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
 


分析与总结:

有N封邮件, 然后又两种操作,如果是M X Y , 表示X和Y是相同的邮件。 如果是S X,那么表示对X的判断是错误的,X是不属于X当前所在的那个集合,要把X分离出来,让X变成单独的一个。


很明显是用并查集来做。 开始让我混淆的一个地方是,假设如下情况

M 0 2

M 1 2

S  2

那么按照并查集来做, 0指向2, 1指向2,即

0 -->2

1 -->2 ,

那么删除2之后,我以为题目意思是所有与2有关系的都要删除, 那么这两个关系都要去掉, 又变成独立的3个了。

但是我这种理解是错的。 合并起来后就是一个集合{0,1,2},  如果把2删除掉之后, {0,1}还是集合。


理解题意之后, 我们知道用并查集来构造集合是很容易的,但是要把集合中的一个删掉,却很不容易。 通过这题,我学习到了所谓的设立虚父节点的方法。

关键的过程是假设要删除x点, 那么不是真的删除x点, 而是通过一个映射(这里用数组majia[N]),把x变成一个新的点即majia[x] = newNode.那么, 原来的那些集合还是不变,只是少了个x点。



代码:

#include<cstdio>
#include<cstring>
#define N 1100000
int f[N],rank[N],majia[N],flag[N],id,n,m;

inline void init(){
    for(int i=0; i<n; ++i)
        f[i]=majia[i]=i;
    memset(rank, 0, sizeof(rank));
    id=n;
}
int find(int x){
    int i, j=x;
    while(j!=f[j]) j=f[j];
    while(x!=j){i=f[x];f[x]=j;x=i;}
    return j;
}
void Union(int x,int y){
    int a=find(x), b=find(y);
    if(a==b)return ;
    if(rank[a]>rank[b])
        f[b]=a;
    else{
        if(rank[a]==rank[b])
            ++rank[b];
        f[a]=b;
    }
}
void Delete(int x){
    f[id]=id;   
    majia[x]=id++;
}


int main(){
    char cmd[3];
    int a,b,cas=1;
    while(~scanf("%d%d",&n,&m)&&n+m){
        init();
        for(int i=0; i<m; ++i){
            scanf("%s",cmd);
            if(cmd[0]=='M'){
                scanf("%d%d",&a,&b);
                Union(majia[a],majia[b]);
            }
            else{
                scanf("%d",&a);
                Delete(a);
            }
        }
        memset(flag, 0, sizeof(flag));
        int ans=0;
        for(int i=0; i<n; ++i){
            a=find(majia[i]);
            if(!flag[a]){
                ++ans;
                flag[a]=1;
            }
        }
        printf("Case #%d: %d\n",cas++, ans);
    }
    return 0;
}


——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值