链接:
http://poj.org/problem?id=3522
题目:
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 4962 | Accepted: 2587 |
Description
Given an undirected weighted graph G, you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).
A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.
Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).
Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.
Your job is to write a program that computes the smallest slimness.
Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.
n | m | |
a1 | b1 | w1 |
⋮ | ||
am | bm | wm |
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2.ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).
Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.
Sample Input
4 5 1 2 3 1 3 5 1 4 6 2 4 6 3 4 7 4 6 1 2 10 1 3 100 1 4 90 2 3 20 2 4 80 3 4 40 2 1 1 2 1 3 0 3 1 1 2 1 3 3 1 2 2 2 3 5 1 3 6 5 10 1 2 110 1 3 120 1 4 130 1 5 120 2 3 110 2 4 120 2 5 130 3 4 120 3 5 110 4 5 120 5 10 1 2 9384 1 3 887 1 4 2778 1 5 6916 2 3 7794 2 4 8336 2 5 5387 3 4 493 3 5 6650 4 5 1422 5 8 1 2 1 2 3 100 3 4 100 4 5 100 1 5 50 2 5 50 3 5 50 4 1 150 0 0
Sample Output
1 20 0 -1 -1 1 0 1686 50
Source
#include<cstdio>
#include<algorithm>
using namespace std;
const int VN = 110;// 点的数量
const int EN = VN*VN; // 边的数量
const int INF = 10000000;
template<typename Type>
class Kruskal{
public:
// n为点的数量
void init(int _n){
n=_n; size = 0; make_set(n); MSTsum = 0;
}
void insert(int u, int v, Type w){
if(u==v)return;
E[size++].set(u,v,w);
}
Type kruskal(){
sort(E, E+size);
int minLen=INF;
for(int i=0; i<size-n+2; ++i){
make_set(n);
int tmp_min=E[i].w, cnt=0;
for(int j=i; j<size; ++j){
if(Union(E[j].u, E[j].v)){
if(++cnt==n-1){
if(E[j].w-tmp_min<minLen)
minLen=E[j].w-tmp_min;
if(minLen==0) return 0; //如果是0,那么已经是最小的了
break;
}
}
}
}
if(minLen==INF) return -1;
return minLen;
}
private:
struct Edge{
int u,v;
Type w;
void set(int a,int b,Type c){u=a; v=b; w=c; }
friend bool operator<(const Edge&a,const Edge&b){
return a.w < b.w;
}
}E[EN];
int f[VN],rank[VN];
int n, size; // n为点的数量, m为边的数量
Type MSTsum;
// 并查集的操作
void make_set(int n){
for(int i=0; i<=n; ++i)
f[i]=i, rank[i]=0;
}
int find(int x){
int i,j=x;
while(j!=f[j]) j=f[j];
while(x!=j){ i=f[x]; f[x]=j; x=i; }
return j;
}
bool Union(int x, int y){
int a=find(x), b=find(y);
if(a==b)return false;
if(rank[a]>rank[b]) f[b]=a;
else{
if(rank[a]==rank[b]) ++rank[b];
f[a] = b;
}
return true;
}
};
Kruskal<int>G;
int n, m;
int main(){
int a,b,c;
while(~scanf("%d%d",&n,&m)&&n+m){
G.init(n);
for(int i=0; i<m; ++i){
scanf("%d%d%d",&a,&b,&c);
G.insert(a,b,c);
}
printf("%d\n", G.kruskal());
}
return 0;
}
—— 生命的意义,在于赋予它意义。
原创 http://blog.csdn.net/shuangde800 , By D_Double (转载请标明)