POJ - 3522 Slim Span(枚举贪心+最小生成树kruskal)

14 篇文章 0 订阅
6 篇文章 0 订阅

点击打开题目链接

Slim Span
Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 7997Accepted: 4257

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.


Figure 5: A graph  G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of  G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm
a1b1w1
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

Source

[Submit]   [Go Back]   [Status]   [Discuss]

刚刚做了一个差不多一样的题,然而这个题还是卡了很长时间。(QAQ以后多练习)

这个题和刚刚题差不多,求生成树的权值最大值与最小值的差。这个题需要判断是否所有点连通,即num是否等于n-1.

附上AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;
const int maxn=100+5;
const int INF=0x7f7f7f7f;
int par[maxn];
int n,m;
int cnt;
int min_;

struct edges{
int a,b,w;
}edge[maxn*maxn];

bool cmp(const edges a1,const edges b1)
{
    return a1.w<b1.w;
}

void init()
{
    for(int i=1;i<=n;i++)
        par[i]=i;
}

int find(int a)
{
    if(a==par[a])return a;
    return par[a]=find(par[a]);
}

void kruskal(int cnt)
{
    for(int i=1;i<=cnt;i++)
    {
        int num=0;
        init();
        for(int j=i;j<=cnt;j++)
        {
            int fx=find(edge[j].a);
            int fy=find(edge[j].b);
            if(fx!=fy)
            {
                if(fx>fy)
                    par[fx]=fy;
                else
                    par[fy]=fx;
                    ++num;
                if(n-1==num)
                {
                    min_=min(min_,edge[j].w-edge[i].w);
                    break;
                }
            }
        }
    }
}

int main()
{
   // freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        init();
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&edge[i].a,&edge[i].b,&edge[i].w);
        sort(edge+1,edge+m+1,cmp);
        min_=INF;
        kruskal(m);
        if(min_==INF)printf("-1\n");
        else printf("%d\n",min_);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值