PO3253(贪心)

POJ3253(贪心)


Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2…N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34
题意

一个木头要做成栏杆,所以要进行切割,每一次所需要的费用就等于切割的木头的长度,求最少的费用。

比如长度为21的木头切成5、8、8。现将21切分成13和8,费用是21;再将13切分成5和8,费用是13,作用总费用是34.

思路

每次选取木头中最小的min1和第二小的min2,令min1的长度为min1+min2的长度,把min2从集合中移除。这样就完成了一次切分的逆过程,直到最后集合中只剩一个数字就是所需最小的开销。

整个过程相当于木材切分的逆过程。在切分的过程中,想要让最终所需的费用最小,每次应该尽可能的让切分的两段段长度差距最小。

代码
public class FenceRepair {
  public static void main(String[] args) {
    // TODO Auto-generated method stub
    Scanner sc = new Scanner(System.in);
    int n = sc.nextInt();
    int[] t = new int[n];
    for (int i = 0; i < n; i++) {
      t[i] = sc.nextInt();
    }
    long ans = 0;
    while (n > 1) {
      int min1 = 0;
      int min2 = 1;
      if (t[min1] > t[min2]) {
        int tmp = t[min1];
        t[min1] = t[min2];
        t[min2] = tmp;
      }
      for (int i = 2; i < n; i++) {
        if (t[i] < t[min1]) {
          min2 = min1;
          min1 = i;
        } else if (t[i] < t[min2]) {
          min2 = i;
        }
      }
      int sum = t[min1] + t[min2];
      ans = ans + sum;
      if (min1 == n - 1) {
        int tmp = t[min1];
        t[min1] = t[min2];
        t[min2] = tmp;
      }
      t[min1] = sum;
      t[min2] = t[n - 1];
      n--;
    }
    System.out.println(ans);
    sc.close();
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值