PO2586(贪心)

POJ2586(贪心)


Y2K Accounting Bug

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
题意

​ 已知一个公司在某一年中,每个月要么固定盈利s、要么固定亏损d。但是具体哪个月盈利、那个月亏损却不得而知。不过可以肯定的是,这一年中,【任意的连续5个月盈亏和必定是亏损(< 0)】。问这年是否存在盈利的可能,若可能盈利,【最大的盈利额】是多少?

思路

在满足连续5个月必亏损的前提下盈利最大化。

从1月开始,尽可能的让每个月盈利,只有无法满足"连续5个月必亏损"的时候才选择亏损。

可能的情况如下:

  • s>=4d

    这种情况下,不满足“连续5个月必亏损”,只能是12个月均亏损

  • s<4d&&2s>=3d

    s<4d,为了保证"连续5个月必亏损",那么连续5个月中必须要有4个月是亏损的,即sddddsddddsd

  • 2s<3d&&3s>=2d

    2s<3d,为了保证"连续5个月必亏损",那么连续5个月中必须要有3个月是亏损的,即ssdddssdddss

  • 3s<2d&&4s>=d

    3s<2d,为了保证"连续5个月必亏损",那么连续5个月中必须要有2个月是亏损的,即sssddsssddss

  • 4s<d

    4s<d,为了保证"连续5个月必亏损",那么连续5个月中必须要有1个月是亏损的,即ssssdssssdss

代码
public class Y2KAccountingBug {
  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    while (sc.hasNextInt()) {
      int s = sc.nextInt();
      int d = sc.nextInt();

      int surplus = 0;
      if (4 * s < d) {
        surplus = 10 * s - 2 * d;
      } else if (3 * s < 2 * d) {
        surplus = 8 * s - 4 * d;
      } else if (2 * s < 3 * d) {
        surplus = 6 * s - 6 * d;
      } else if (s < 4 * d) {
        surplus = 3 * s - 9 * d;
      } else {
        surplus = -1;
      }
      if (surplus < 0) {
        System.out.println("Deficit");
      } else {
        System.out.println(surplus);
      }
    }
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值