HDOJ 1312 Red and Black 深搜 DFS 问题>update>2016年7月28日11:53:05

Red and Black

update>2016年7月28日11:53:05>增加自己的代码
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6
13
参考题意:
给我们一张地图,只能在黑色区域走(就是‘ . ')问最多能够走多少步
2016年7月28日11:51:40
自己敲一遍:
#include<stdio.h>
#include<string.h>
#define MYDD 32

char map[MYDD][MYDD];//给定的地图
int vis[MYDD][MYDD];//标记访问记录
//'.' 黑色(可走)
//'#' 红色 (不可走)
//'@' 人所处位置
int wide,hight,step;//宽度,高度,步数
int dx[]= {0,0,-1,1};
int dy[]= {-1,1,0,0}; //可以移动的坐标

void DFS(int sx,int sy) {
	if(sx<0||sy<0||sx>=hight||sy>=wide)
		return ;//当前位置在地图之外
	if(map[sx][sy]=='#'||vis[sx][sy])
		return ;//遇到红色或者已经访问过的坐标
	step++;
	vis[sx][sy]=1;
	for(int j=0; j<4; j++)
		DFS(sx+dx[j],sy+dy[j]);
}

int main() {
	while(scanf("%d%d",&wide,&hight)&&(wide||hight)) {
		memset(vis,0,sizeof(vis));
		int sx,sy;//人的坐标点
		for(int j=0; j<hight; j++) {
			scanf("%s",map[j]);
			for(int k=0; k<wide; k++) {
				if(map[j][k]=='@') {
					sx=j;
					sy=k;//记录开始坐标 
				}
			}
		}
		step=0;
		DFS(sx,sy);
		printf("%d\n",step);
	}
	return 0;
}




参考的学长代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAXN=25;
char mp[MAXN][MAXN];
int vis[MAXN][MAXN];
int disx[4]= {0,0,1,-1};
int disy[4]= {1,-1,0,0};
int W,H,step;
void dfs(int r,int l) {
	if(r<0||r>=H||l<0||l>=W)return;
	if(mp[r][l]=='#'||vis[r][l])return;
	step++;
	vis[r][l]=1;
	for(int i=0; i<4; i++)
		dfs(r+disx[i],l+disy[i]);
}
int main() {
	while(scanf("%d%d",&W,&H),W|H) {
		memset(vis,0,sizeof(vis));
		int r,l;
		for(int i=0; i<H; i++) {
			scanf("%s",mp[i]);
			for(int j=0; j<W; j++)
				if(mp[i][j]=='@')r=i,l=j;
		}
		step=0;
		dfs(r,l);
		printf("%d\n",step);
	}
	return 0;
}//备注:对于我这个初学者,搜索问题还是一头雾水,这是学长提供的答案代码。











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值