Light OJ - 1008- Fibsieve`s Fantabulous Birthday 暑期小练习

Light OJ - 1008- Fibsieve`s Fantabulous Birthday

S - S

Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Submit Status

Description

Fibsieve had afantabulous (yes, it's an actual word) birthday party this year. He had so manygifts that he was actually thinking of not having a party next year.

Among these giftsthere was an N x N glasschessboard that had a light in each of its cells. When the board was turned ona distinct cell would light up every second, and then go dark.

The cells would lightup in the sequence shown in the diagram. Each cell is marked with the second inwhich it would light up.

(Thenumbers in the grids stand for the time when the corresponding cell lights up)

In the first secondthe light at cell (1, 1) would be on. And in the 5th second the cell (3, 1)would be on. Now, Fibsieve is trying to predict which cell will light up at acertain time (given in seconds). Assume that N is large enough.

Input

Input starts with aninteger T (≤ 200), denotingthe number of test cases.

Each case willcontain an integer S (1 ≤ S ≤ 1015) whichstands for the time.

Output

For each case youhave to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case1: 2 3

Case2: 5 4

Case3: 1 5

 


题意:找规律吧,看队友们都写得好容易昂,,,可我却是参考的尴尬尴尬

http://blog.csdn.net/kenden23/article/details/24176645  不知道是哪个学长的,,,,,


代码:

/*=============================AC情况===============================*/
/*题目网址:   */
/*时间: */
/*心得:  */

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#define G 100

int main() {
	int T=0;
	long long s,x,y;
	scanf("%d",&T);
	for(int j=1; j<=T; j++) {
		scanf("%lld",&s);
		x=1;
		y=sqrt(s);
		s -= (y*y); 
		if(s==0)
			s+=1+2*(y-1); 
		else
			y++;
		if(y%2==0&&s<=y) x=s;
		else if(y%2&&s<=y) {
			x=y;
			y=s;
		} else if(y%2==0&&s>y) {
			x=y;
			y=y-(s-y);
		} else if(y%2&&s>y) {
			x=y-(s-y);
		}
		printf("Case %d: %lld %lld\n",j,x,y);
	}
	//printf("\n");}
	return 0;
}

/*********************************测试数据*********************************


**************************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值