Light OJ - 1008 - Fibsieve`s Fantabulous Birthday

Description

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题意及思路:输入一个数N,输出其所在坐标。此题重点是找规律。从图中可以看出,每个走向的方格数分别是1,3,5,7......,每个走向中的数开平方取大于它最小的整数(比如说3开平方等于1.732,取大于它最小的正数即为2)都是相同的,此处是用ceil函数(功能:返回大于或者等于指定表达式的最小整数)实现的,假设每个走向所取的整数为m,这个走向中的任意一个方格中的数为n,如果m%2==0,如果m*m-n<n,则这个方格的横坐标x为m,纵坐标y为m*m-n+1;如果不满足上述条件,则纵坐标y确定为m,再次观察可以发现,横坐标和(m*m-n)的和为(2*m-1);如果m%2!=0,则x和y互换。(为什么用long long 可以,用__int64 就超时,求大神指点)。

代码如下:

#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
	int l;
	scanf("%d",&l);
	int ant=1; 
	while(l--)
	{
		long long n;
		long long x,y,t;
		scanf("%lld",&n);
		__int64 m=ceil(sqrt(n));
		if(m%2==0)
		{
			if(m*m-n<m)
			{
			x=m;
			y=m*m-n+1;	
			}
			else
			{
				y=m;
				x=2*m-1-(m*m-n);
			}
		
		}
		if(m%2!=0)
		{
		if(m*m-n<m)
			{
			y=m;
			x=m*m-n+1;	
			}
			else
			{
				x=m;
				y=2*m-1-(m*m-n);
			}
		}
		printf("Case %d: %lld %lld\n",ant++,x,y);
	}
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值