POJ 3278 Catch That Cow(这些年追大牛的我们,BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74867 Accepted: 23632

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source



题意:

骈死于槽里之间。牛受不了环境和待遇,私自跑了,你要去追牛(这牛不知道你还会去追她,就在休息的地方一动不动的),你有两种方式行走:

左右一步移动和加倍移动,如你在坐标点位置 10,可以移动到 20>>40>>80>>79>>78>>156.... 答案求解的是最好的方法需要多长时间。


思路:

BFS,顺着敲一遍吧~~~~~~~~


代码:

#include<cstdio>
#include<queue>
#include<cstring>
#define MYDD 110300

using namespace std;

queue<int> q;
int farmer[MYDD];
int cow[MYDD];
int n,k,ans,y;//农夫和牛的初始位置, y 队首元素 
void BFS() {
	farmer[n]= 0;
	q.push(n);
	while(q.size()!=0) {
		y=q.front();
		q.pop();
		cow[y]=1;
		if(y==k) {
//			ans=farmer[y];
			break;
		}
		if(y-1>=0&&cow[y-1]==0) {
			q.push(y-1);
			farmer[y-1]=farmer[y]+1;
			cow[y-1]=1;
		}
		if(y+1<=100000&&cow[y+1]==0) {
			q.push(y+1);
			farmer[y+1]=farmer[y]+1;
			cow[y+1]=1;
		}
		if(2*y<=100000&&cow[2*y]==0) {
			q.push(2*y);
			farmer[2*y]=farmer[y]+1;
			cow[2*y]=1;
		}
	}
}

int main() {
	while(scanf("%d%d",&n,&k)!=EOF) {
		BFS();
		printf("%d\n",farmer[y]);
//		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值