POJ 2367 Genealogical tree(系谱图,拓扑排序)

7 篇文章 0 订阅
7 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4646 Accepted: 3085 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source



题意:

火星人的种族关系混乱,即使有十个父亲,一百个孩子也不为过。(最起码是人,这出题人是不是反伦理昂!!)

给定我们一些数据,排序输出例如 :

a b c d e 表示 b 是 a 的孩子;c 是 d 的孩子.....就是家族系谱图吧。


键入数据提示:
人口数目 n

第 1 个人的孩子 (键入 0 结束)

第 2 个人的孩子 (键入 0 结束)

第 n-1 个人的孩子 (键入 0 结束)

第 n 人的孩子 (键入 0 结束)


思路:

理解题意,看懂测试数据可以试着敲一下代码。
简单的拓扑排序,这里用二维数组方式来实现,也可以尝试用队列的方式。


代码:

实现方式:二维数组

#include<stdio.h>
#include<string.h>
const int MYDD=1103;

int indegree[MYDD];
int map[113][113];
int ans[MYDD];//记录排序顺序
void TopoSort(int x) {
	int now,dd=1;// now 当前选中的节点; dd ans[]数组的大小
	for(int j=1; j<=x; j++) {
		for(int i=1; i<=x; i++) {
			if(!indegree[i]) {
				now=i;
				break;//入度为 0 即前驱
			}
		}
		ans[dd++]=now;
		indegree[now]=-1;//标记前驱数量为 -1
		for(int i=1; i<=x; i++)//当前节点的后继节点入度 -1
			if(map[now][i])     indegree[i]--;
	}
}

int main() {
	int n;
	scanf("%d",&n);
	memset(indegree,0,sizeof(indegree));
	memset(map,0,sizeof(map));
	for(int j=1; j<=n; j++) {
		int v;
		scanf("%d",&v);
		while(v) {
			map[j][v]=1;
			indegree[v]++;//入度的增加
			scanf("%d",&v);
		}
	}

	TopoSort(n);//拓扑排序

	for(int j=1; j<=n; j++)	printf("%d ",ans[j]);
	return 0;
}


后:

********************



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值