[hihocoder taige 20-1]括号配对

问题描述

题目1 : Parentheses Matching
时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
Given a string of balanced parentheses output all the matching pairs.

输入
A string consisting of only parentheses ‘(’ and ‘)’. The parentheses are balanced and the length of the string is no more than 100000.

输出
For each pair of matched parentheses output their positions in the string.

样例输入
(())()()
样例输出
1 4
2 3
5 6
7 8

算法思路

‘)’每次与最近的未配对的’(‘配对,只需要维护一个栈即可。

全部代码

#include <iostream>
#include <stack>

using namespace std;

char str[100002];
int match[100002];

int main()
{
    cin >> str;

    stack<int> s;
    int index = 0;

    while (str[index]) {
        if (str[index] == '(')
                s.push(index);
        else if (str[index] == ')'){
            match[s.top()] = index+1;
            s.pop();
        }
        ++index;
    }

    for (int i = 0;i < index;++i)
        if (match[i] > 0)
            cout << i+1 << ' ' << match[i] << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值