MyEclipse2017 下'Publishing to Tomcat 8.5。。。'has encountered a problem解决办法

MyEclipse2017 下'Publishing to Tomcat 8.5。。。'has encountered a problem

详情detail:

Tomcat version 8.5 requires Java SE 7 or later Change the JRE to one that meets

解决方法:

 tomcat版本太高了 8.0版本  这个JDK就应用1.7及以上的版本

有可能是工作空间默认的jdk版本太低了,查看点击工程右键选择properties,如下图:

如何修改,点击上方菜单window,选择preference,出现下图,选择红框内容,勾选即可


2、修改项目build path的JDK配置

项目-》build path-》JDK换成1.7的

Java Compiler-》JDK Compliance 选择1.7

Project Facets -》Java 选择1.7



阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页