hdu 5349 MZL's simple problem(简单的SET容器)

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=5349

MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1654    Accepted Submission(s): 652


Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N  ( N106 ),representing the number of operations.
Next  N  line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
  
  
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
  
  
3 4
 

这道题基本是裸的SET。。唯一要注意的就是当删除的时候要判断SET是否为空

#include <stdio.h>
#include <set>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    scanf("%d", &n);
    set <int> st;
    st.clear();
     set<int>::iterator ip;
    for(int i = 1;i <= n;i++)
    {
        int q;
        scanf("%d", &q);
        if(q==1)
        {
            int t;
            scanf("%d", &t);
            st.insert(t);
        }
        else if(q==2)
        {

            if(!st.empty())
                st.erase(st.begin());

        }
        else if(q==3)
        {
            if(st.empty())
                printf("0\n");
            else
            {

                printf("%d\n",*--st.end());
            }
        }
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值