hdu2196Computer(树形dp)

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5837    Accepted Submission(s): 2927


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 
这题的题意是给你一个图,问你每个节点能到达的最远距离为多少?

这是一道十分经典的树形DP了,两个dfs,第一个dfs找到所有子节点能到达的最远距离和次远距离,第二个dfs就是从父节点更新这些距离

AC代码:


<span style="font-family:Verdana;">#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=11000;
/*
int maxn[MAXN];该节点往下到叶子的最大距离
int smaxn[MAXN];次大距离
int maxid[MAXN];最大距离对应的序号
int smaxid[MAXN];次大的序号
*/
struct Edge{
	int from,to,cost,next;
	Edge(){}
	Edge(int from,int to,int cost,int next){
		this->from=from;
		this->to=to;
		this->cost=cost;
		this->next=next;
	}
}e[MAXN*2];
int head[MAXN*2],maxn[MAXN];
int maxid[MAXN],smaxn[MAXN],smaxid[MAXN],tot;
void init(){
	memset(head,-1,sizeof(head));
	tot=0;
}
void add_edge(int u,int v,int c){
	e[tot]=Edge(u,v,c,head[u]);
	head[u]=tot++;	
	e[tot]=Edge(v,u,c,head[v]);
	head[v]=tot++;
}

void dfs1(int u,int fa){
	maxn[u]=0;
    smaxn[u]=0;
	for(int i=head[u];i!=-1;i=e[i].next){
		int v=e[i].to;
		//cout<<u<<" "<<v<<endl;
		if(v==fa)	continue;
		dfs1(v,u);
		if(smaxn[u]<maxn[v]+e[i].cost){
			smaxn[u]=maxn[v]+e[i].cost;
			smaxid[u]=v;
			if(smaxn[u]>maxn[u]){
				swap(smaxn[u],maxn[u]);
				swap(smaxid[u],maxid[u]);
			}
		}
	}
}
void dfs2(int u,int fa){
	for(int i=head[u];~i;i=e[i].next){
		int v=e[i].to;
		if(v==fa)	continue;
		if(v==maxid[u]){
			if(e[i].cost+smaxn[u]>smaxn[v]){
				smaxn[v]=e[i].cost+smaxn[u];
				smaxid[v]=u;
				if(smaxn[v]>maxn[v]){
					swap(smaxn[v],maxn[v]);
					swap(smaxid[v],maxid[v]);
				}
			}
		}
		else{
			if(e[i].cost+maxn[u]>smaxn[v]){
				smaxn[v]=e[i].cost+maxn[u];
				smaxid[v]=u;
				if(smaxn[v]>maxn[v]){
					swap(smaxn[v],maxn[v]);
					swap(maxid[v],smaxid[v]);
				}
			}
		}
		dfs2(v,u);
	}
} 
int main(){
	int t;
	while(~scanf("%d",&t)){
		init();
		for(int v=2;v<=t;v++){
			int u,w;
			scanf("%d%d",&u,&w);
			add_edge(v,u,w);
		}
		dfs1(1,-1);
		dfs2(1,-1);
		for(int i=1;i<=t;i++)
			printf("%d\n",maxn[i]);
	}
	return 0;
}</span>



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值