PAT 1134.Vertex Cover(25 分)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

使边全覆盖  

#include <stdio.h>
#include <vector>
using namespace std;
int main()
{
    int n,m,k,nv;
    scanf("%d %d",&n,&m);
    vector<int> v[n];
    for(int i=0;i<m;i++)
    {
        int a,b;
        scanf("%d %d",&a,&b);
        v[a].push_back(i);
        v[b].push_back(i);
    }
    scanf("%d",&k);
    while(k--)
    {
        scanf("%d",&nv);
        vector<int> hash(m,0);
        bool flag = true;
        for(int i =0;i<nv;i++)
        {
            int index;
            scanf("%d",&index);
            for(int j = 0;j<v[index].size();j++)
            {
                hash[v[index][j]]=1;
            }
        }
        for(int i = 0;i < m;i++)
        {
            if(hash[i] == 0)
            {
                printf("No\n");
                flag = false;
                break;
            }
        }
        if(flag)
        {
            printf("Yes\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值