1134 Vertex Cover(34行代码+详细注释)

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv​ v[1] v[2]⋯v[Nv​]

where Nv​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

代码长度限制

16 KB

时间限制

600 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=10009,INF=0x3f3f3f3f;
int n,m;
map<int,int>mp;
struct edge{
    int a,b;
}e[N];
int main(){
    cin>>n>>m;//v,e
    for(int i=0;i<m;i++){//输入边 
        cin>>e[i].a>>e[i].b;
    }
    int k;
    cin>>k;
    while(k--){//k次查询 
         int num;
         cin>>num;//顶点数
         while(num--){//输入顶点集 
             int node;
             cin>>node;
             mp[node]=1;//记录出现过的顶点
        }
        int flag=1;//1表示顶点覆盖,0则不是 
        for(int i=0;i<m;i++){//遍历每条边 
            int a=e[i].a,b=e[i].b;//当前边的两个端点 
            if(!mp.count(a)&&!mp.count(b))flag=0;//若该条边的两个端点都没有出现在该点集里则不是顶点覆盖 
        }
        if(flag)puts("Yes");
        else puts("No");
        mp.clear();//每次查询完需清空map 
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值