HDU 1102 Constructing Roads(最小生成树)

问题描述:
Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

大致题意:
要使所有点连通,求最小花费。
有的点已经连上了。

思路分析:
最小生成树基本T~

ac代码;

#include <iostream>
#include <queue>
#include<stdio.h>
using namespace std;
const long MAXN=10000;
long father[MAXN];
long m,n;//点数 边数
//m标号从1开始
typedef struct
{
    long from;
    long to;
    long cost;
}Edge;

bool operator <(const Edge &a, const Edge &b)
{
    return a.cost>b.cost;
}
priority_queue<Edge> q;
Edge e[100005];
void MakeSet()
{
    long i;
    for (i=0;i<=m;++i)
    {
        father[i]=i;
    }
}
long Find(long i)
{
    long r=i;
    while (father[r]!=r)
    {
        r=father[r];
    }
    while (father[i]!=r)
    {
        long j=father[i];
        father[i]=r;
        i=j;
    }
    return r;
}
void Unition(long x,long y)
{
    long fx=Find(x);
    long fy=Find(y);
    if (fx!=fy)
    {
        father[fx]=fy;
    }
}
void Init()
{
    while (!q.empty())
    {
        q.pop();
    }
    MakeSet();
    long i,j;
    long cc;
    int pp=0;
    for(i=1;i<=m;++i)
    {
        for(j=1;j<=m;j++)
        {
            scanf("%ld",&cc);
            e[pp].from=i;
            e[pp].to=j;
            e[pp].cost=cc;
            pp++;
        }
    }
    long qqq,aaa,bbb;
    scanf("%ld",&qqq);
    for(i=0;i<qqq;i++)
    {
        scanf("%ld%ld",&aaa,&bbb);
        for(j=0;j<pp;j++)
        {
            if(e[j].from==aaa)
            {
                if(e[j].to==bbb)
                {
                    e[j].cost=0;
                }
            }
            if(e[j].from==bbb)
            {
                if(e[j].to==aaa)
                {
                    e[j].cost=0;
                }
            }
        }
    }
    for(i=0;i<pp;i++)
    {
        q.push(e[i]);
    }
}
void print(long cost)
{
    printf("%ld\n",cost);
}
void Kruskal()
{
    Init();
    long t=0;//表示合并次数
    long cost=0;
    Edge e;
    while (!q.empty()&&t<m-1)
    {
        e=q.top();
        long v1=e.from;
        long v2=e.to;
        if (Find(v1)!=Find(v2))
        {
            Unition(v1,v2);
            cost+=e.cost;
            ++t;
        }
        q.pop();
    }
    print(cost);
}

int main()
{
    while(~scanf("%ld",&m))//输入点与边
    {
        Kruskal();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值