ZOJ 3228 Searching the String(AC自动机)

Little jay really hates to deal with string. But moondy likes it very much, and she’s so mischievous that she often gives jay some dull problems related to string. And one day, moondy gave jay another problem, poor jay finally broke out and cried, ” Who can help me? I’ll bg him! ”
So what is the problem this time?
First, moondy gave jay a very long string A. Then she gave him a sequence of very short substrings, and asked him to find how many times each substring appeared in string A. What’s more, she would denote whether or not founded appearances of this substring are allowed to overlap.
At first, jay just read string A from begin to end to search all appearances of each given substring. But he soon felt exhausted and couldn’t go on any more, so he gave up and broke out this time.
I know you’re a good guy and will help with jay even without bg, won’t you?
Input
Input consists of multiple cases( <= 20 ) and terminates with end of file.
For each case, the first line contains string A ( length <= 10^5 ). The second line contains an integer N ( N <= 10^5 ), which denotes the number of queries. The next N lines, each with an integer type and a string a ( length <= 6 ), type = 0 denotes substring a is allowed to overlap and type = 1 denotes not. Note that all input characters are lowercase.
There is a blank line between two consecutive cases.
Output
For each case, output the case number first ( based on 1 , see Samples ).
Then for each query, output an integer in a single line denoting the maximum times you can find the substring under certain rules.
Output an empty line after each case.
Sample Input
ab
2
0 ab
1 ab
abababac
2
0 aba
1 aba
abcdefghijklmnopqrstuvwxyz
3
0 abc
1 def
1 jmn
Sample Output
Case 1
1
1
Case 2
3
2
Case 3
1
1
0

/*
AC自动机. 
串分为可重复的和不可重复的. 
对于可重复的,直接统计.
对于不可重复的,记录一下最后一次匹配的位置 然后判断.
这题数据范围好像有错误.
我低估了数据 串有重复的,然后记一下就好了. 
*/
#include<cstring>
#include<queue>
#include<cstdio>
#define MAXN 600010
using namespace std;
int n,l,tot=1,fail[MAXN],flag[MAXN],len[MAXN],p[MAXN][2],ans[MAXN][2],lastmark[MAXN],pos[MAXN];
char s[MAXN],ch[MAXN];
struct data{int x[27],b[2];}tree[MAXN];
queue<int>q;
void add(bool f,int t)
{
    l=strlen(s+1);flag[t]=f;len[t]=l;int now=1;
    for(int i=1;i<=l;i++)
    {
        int x=s[i]-96;
        if(!tree[now].x[x]) tree[now].x[x]=++tot;
        now=tree[now].x[x];
    }
    tree[now].b[f]=1;p[now][f]=t;pos[t]=now;
    return ;
}
void Clear()
{
    memset(lastmark,0,sizeof lastmark);
    memset(ch,0,sizeof ch);
    memset(fail,0,sizeof fail);
    memset(tree,0,sizeof tree);
    memset(ans,0,sizeof ans);
    tot=1;return ;
}
void get_fail()
{
    for(int i=1;i<=26;i++) tree[0].x[i]=1;
    q.push(1);
    while(!q.empty())
    {
        int now=q.front();q.pop();
        for(int i=1;i<=26;i++)
        {
            if(!tree[now].x[i]) continue;
            int k=fail[now];
            while(!tree[k].x[i]) k=fail[k];
            k=tree[k].x[i];
            fail[tree[now].x[i]]=k;
            q.push(tree[now].x[i]);
        }
    }
    return ;
}
void Mark()
{
    l=strlen(ch+1);int now=1;
    for(int i=1;i<=l;i++)
    {
        int x=ch[i]-96;
        while(!tree[now].x[x]) now=fail[now];
        now=tree[now].x[x];
        int k=now;
        while(k)
        {
            if(tree[k].b[1])// not can.
            {
                if(!lastmark[p[k][1]]||lastmark[p[k][1]]+len[p[k][1]]<=i)
                {
                    ans[k][1]+=tree[k].b[1];
                    lastmark[p[k][1]]=i;
                }
            }
            if(tree[k].b[0]) ans[k][0]+=tree[k].b[0];// can.
            k=fail[k];
        }
    }
    for(int i=1;i<=n;i++) printf("%d\n",ans[pos[i]][flag[i]]);
    printf("\n");
}
int main()
{
    int x,Case=0;
    while(scanf("%s",ch+1)!=EOF)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d %s",&x,s+1),add(x,i);
        get_fail();
        printf("Case %d\n",++Case);
        Mark();Clear();
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值