Stall Reservations POJ 3190

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A…B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input
Line 1: A single integer, N

Lines 2…N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.

Output
Line 1: The minimum number of stalls the barn must have.

Lines 2…N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input
5
1 10
2 4
3 6
5 8
4 7

Sample Output
4
1
2
3
2
4

Hint
Explanation of the sample:

Here’s a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>
Stall 2 … c2>>>>>> c4>>>>>>>>> … …
Stall 3 … … c3>>>>>>>>> … … … …
Stall 4 … … … c5>>>>>>>>> … … …
Other outputs using the same number of stalls are possible.

思路:
优先处理产奶时间靠前且结束时间靠前的奶牛,因此将奶牛的产奶开始时间先进行排序,再通过优先数组的方式,寻找结束时间的最小值,若最小值大于开始时间,则应增加栏位。

代码

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <string>

using namespace std;
const int N=50000;
struct Cow
{
   int no;
   int start,End;
   int stall;
   friend bool operator < (Cow a,Cow b)
   {
       return a.End > b.End;
   }
}cow[N];
bool cmp1(Cow a,Cow b)
{
    return a.start<b.start;
}
bool cmp2(Cow a,Cow b)
{
    return a.no<b.no;
}
priority_queue<Cow> que;
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d %d",&cow[i].start,&cow[i].End);
        cow[i].no=i;
    }
    sort(cow,cow+n,cmp1);
    cow[0].stall=1;
    que.push(cow[0]);
    int l=1;
    for(int i=1;i<n;i++)
    {
        Cow temp=que.top();
        if(temp.End>=cow[i].start)
        {
            l++;
            cow[i].stall=l;
            que.push(cow[i]);
        }
        else
        {
            cow[i].stall=temp.stall;
            que.pop();
            que.push(cow[i]);
        }
    }
    sort(cow,cow+n,cmp2);
    printf("%d\n",l);
    for(int i=0;i<n;i++)
    {
        printf("%d\n",cow[i].stall);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值