Hdu 4565 So Easy! 矩阵快速幂+共轭数

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4352    Accepted Submission(s): 1421


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 

Source

重要条件:(a-1)2< b < a2
由此可得0<(a-sqrt(b))^n<1
(a+sqrt(b))^n=xn+ynsqrt(b),则(a+sqrt(b))^n+(a-sqrt(b))^n=2*Xn是整数,而后面的部分又小于1,所以答案就是2*Xn.
(a+sqrt(b))^(n+1)=(xn+ynsqrt(b))*(a+sqrt(b))=aXn+bYn+(Xn+bYn)sqrt(b)=Xn+1 + Yn+1,可以使用矩阵快速幂求得答案。

#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;
typedef long long ll;
const int size=2;
ll m;

struct Matrix {
	ll a[size][size];
};

Matrix operator*(const Matrix &x,const Matrix &y) {
	int i,j,k;
	Matrix ans;
	for (i=0;i<size;i++) {
		for (j=0;j<size;j++) {
			ans.a[i][j]=0;
			for (k=0;k<size;k++) {
				ans.a[i][j]+=x.a[i][k]*y.a[k][j];
				ans.a[i][j]%=m;
			}
		}
	} 
	return ans;
}

Matrix fastpower(Matrix base,ll index) {
	Matrix ans,now;
	int i,j;
	for (i=0;i<size;i++) {
		for (j=0;j<size;j++) {
			if (i==j) ans.a[i][j]=1; else ans.a[i][j]=0;
		}
	}
	now=base;
	ll k=index;
	while (k) {
		if (k%2) ans=ans*now;
		now=now*now;
		k/=2;
	}
	return ans;
}

int main() {
	ll a,b,n;
	while (scanf("%lld%lld%lld%lld",&a,&b,&n,&m)!=EOF) {
		Matrix x;
		x.a[0][0]=x.a[1][1]=a;
		x.a[0][1]=b;x.a[1][0]=1;
		Matrix sum=fastpower(x,n);
		ll ans=sum.a[0][0];
		ans*=2;
		ans%=m;
		printf("%lld\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值