POJ 1651 Multiplication Puzzle 区间DP

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10664 Accepted: 6659

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion


给n个数字,要删掉中间n-2个,每次删除的代价是自己的数乘左右两边的数的乘积,问最小代价是多少。


显然如果删去的区间不连续,则代价是彼此独立的,所以适合用区间DP解决。

dp[i][j]表示删去 i 到 j 连续的一段区间的最小代价,设最后删除的数字的位置为k,则

dp[j][j+i]=min(dp[j][k-1]+dp[k+1][j+i]+a[k]*a[j-1]*a[j+i+1])

除了这种情况,还需要考虑k正好在区间两边的情况。


#include <cstdio>
#include <iostream>
#include <string.h>
#include <string> 
#include <map>
#include <queue>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <stack>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef double db;
const int maxn=105,inf=0x3f3f3f3f;  
const ll llinf=0x3f3f3f3f3f3f3f3f;   
const ld pi=acos(-1.0L);
ll dp[maxn][maxn],a[maxn];

int main() {
	int n,i,j,k;
	scanf("%d",&n);
	for (i=1;i<=n;i++) 
		scanf("%lld",&a[i]);
	meminf(dp);
	for (i=2;i<n;i++) dp[i][i]=a[i-1]*a[i]*a[i+1]; 
	for (i=1;i<=n-2;i++) {
		for (j=2;j+i<n;j++) {
			dp[j][j+i]=min(dp[j][j+i],dp[j+1][j+i]+a[j]*a[j-1]*a[j+i+1]);
			dp[j][j+i]=min(dp[j][j+i],dp[j][j+i-1]+a[j+i]*a[j-1]*a[j+i+1]);
			for (k=j+1;k<j+i;k++) {
				dp[j][j+i]=min(dp[j][j+i],dp[j][k-1]+dp[k+1][j+i]+a[k]*a[j-1]*a[j+i+1]);
			}
	//		cout << j << ' ' << j+i << ' ' << dp[j][j+i] << endl;
		}
	}
	printf("%lld\n",dp[2][n-1]);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值