Coins

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
 
Sample Output
8
4
 
 
Source
2009 Multi-University Training Contest 3 - Host by WHU
 
Recommend
gaojie
 

题目大意:n种数,每个数的值为ai,有ci个,求能组成多少个不大于m的不同的数字

思路:

实际上就是一个背包问题,只是多开一个数组,用来记录第i种使用了多少个!其余两重循环就是背包问题,注意第二重不是从0开始,而是从a[i]开始!!!还有一个就是判断条件问题,用dp表示能不能组成这个数,

代码;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define maxn 15
const int MAXN = 1e5+5;
#define mod 1000000007
#define INF 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;
int main()
{
   // freopen("D:\\a.txt","r",stdin);
    ios::sync_with_stdio(false);
    int n,m,i,j,k;
    int a[MAXN],c[MAXN];
    int dp[MAXN],s[MAXN];
    int sum;
    while(cin>>n>>m,n+m)
    {
    	sum=0;
    	for(i=1;i<=n;i++)
    	cin>>a[i];
    	for(i=1;i<=n;i++)
    	cin>>c[i];
    	memset(dp,0,sizeof(dp));
    	dp[0]=1;
    	for(i=1;i<=n;i++)
    	{
    		memset(s,0,sizeof(s));
    		for(j=a[i];j<=m;j++)
    		{
			if(!dp[j]&&dp[j-a[i]]&&s[j-a[i]]<c[i])     //关键点和难点
			{
				dp[j]=1;
				sum++;
				s[j]=s[j-a[i]]+1;
			}	
    	    }
    	}
    	cout<<sum<<endl;
    }
    return 0;
}
    


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值