Ping pong(树状数组)

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5458    Accepted Submission(s): 2032


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
1
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2485  2491  2490  2489  2488 
 

题意: 一条大街上住着n个乒乓球爱好者,他们经常组织乒乓球比赛且每个人的能力值ai都不同.每次比赛需要2个比赛者和一个裁判,他们有一个奇怪的规定:当裁判的那个人必须住在这两个比赛者之间,且裁判的能力值也必须在这两个人之间.问一共有多少种比赛组织方式.

 输入:首先是T(1<=T<=20),表示实例个数.对于每个实例第一行是一个n(3<=n<=20000),然后是n个不同的整数即a1,a2…an(1<=ai<=100000),按照他们的住所位置从左到右给出每个人的能力值.

输出:比赛组织的总数.
分析: 对于第i个(任意一个)裁判,他能组织多少种比赛呢?
假设a1到ai-1有S_L[i]个能力值比ai小的,那么有i-1-S_L[i]个能力值比ai大的.同理可得S_R[i]为从i+1到n有B[i]个人能力值比ai小.那么i当裁判能组织的比赛种数是:S_L[i]*(n-i-S_R[i])+(i-1-S_L[i])*S_R[i]种. 我们只需要求出所有裁判的S_L[i]和S_R[i]即可求出所有比赛种数。如何求S_L[i]呢(即在a[i]左边且比a[i]值小的数个数)? 我们令X[n]作为标记数组,假设当前我们扫描到了第i个点,此时如果X[y]==1,那么表示第i个点左边出现了一个a[k]==y的值且k<i。那么这时,我们只要用树状数组计算X[n]数组中区间[1, a[i]-1]的和即可(想想是不是)。

(注意一开始是c初始化为0.然后在逐个加1)状数组中区间求和函数:该函数的作用是用于求序列中小于等于数字 i 的元素的个数。这个是显而易见的,因为树状数组c 维护的是数组A的值,则该求和函数即是用于求下标小于等于 i 的数组A的和,而数组A中元素的值要么是0要么是1,所以最后求出来的就是小于等于i的元素的个数。



代码:


#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#define maxn 20005
#define maxm 100005
using namespace std;
int a[maxn],c[maxm],l[maxm],r[maxm];//a是能力值,c是树状数组,l是左边小于它得数的个数,r是右边。
int maxx;
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int v)//使得C数组的所有包含a[x]的项都加上v
{
    while(x<=maxx)  //maxx是能力值得上限
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
int sum(int x)  //求a[1]到a[x]的和。
{
    int res=0;
    while(x>0)
    {
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}

int main()
{

    ios::sync_with_stdio(false);
    int t,n,i;
    cin>>t;
    while(t--)
    {
        maxx=0;
        cin>>n;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
            if(maxx<a[i])maxx=a[i];
        }
        memset(c,0,sizeof(c));
        for(i=1;i<=n;i++)  //从左往右,注意是在a[i]的基础之上。
        {
            l[i]=sum(a[i]);
            add(a[i],1);
        }
        memset(c,0,sizeof(c));
        for(i=n;i>=1;i--)      //从右往左
        {
            r[i]=sum(a[i]);
            add(a[i],1);
        }
        long long ans=0;
        for(i=1;i<=n;i++)
        {
            ans+=(long long)l[i]*(n-i-r[i])+(long long)(i-1-l[i])*r[i];
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值