Ping pong 利用树状数组存储

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4174

利用树状数组储存能力值

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street? Input The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases, followed by T lines each of which describes a test case. Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east (1 ≤ ai ≤ 100000, i = 1 . . . N). Output For each test case, output a single line contains an integer, the total number of different games. Sample Input 1 3 1 2 3 Sample Output 1

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=20000+100;
const int MAX_NUM=100000+100;
int S_L[MAXN],S_R[MAXN];
int x[MAX_NUM];
int c[MAX_NUM];
int a[MAXN];//能力值
int max_a;
int lowbit(int i)
{
    return i&(-i);
}
int sum(int i)//求从A[1]到A[i]的和
{
    int res=0;
    while(i>0)
    {
        res += c[i];
        i-=lowbit(i);
    }
    return res;
}
void add(int i,int d)//使得C数组的所有包含A[i]的项都加上d
{
    while(i<=max_a)//这里max_a 是能力值的上限
    {
        c[i]+=d;
        i += lowbit(i);
    }
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        max_a=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            max_a=max(max_a,a[i]);
        }

        memset(c,0,sizeof(c));
        for(int i=1; i<=n; i++)
        {
            S_L[i]=sum(a[i]);//从左边看;
            add(a[i],1);//利用树状数组求解,类似于数组,但是求区间和效率高;
        }
        memset(c,0,sizeof(c));
        for(int i=n; i>=1; i--)
        {
            S_R[i]=sum(a[i]);
            add(a[i],1);
        }
        long long ans=0;
        for(int i=1; i<=n; i++)
        {
            ans += (long long)S_L[i]*(n-i-S_R[i])+(long long)(i-1-S_L[i])*S_R[i];
        }
        printf("%lld\n",ans);//注意UVA关于64位整数的格式
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值