City Skyline(单调队列)

City Skyline
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2969 Accepted: 1367

Description

The best part of the day for Farmer John's cows is when the sun sets. They can see the skyline of the distant city. Bessie wonders how many buildings the city has. Write a program that assists the cows in calculating the minimum number of buildings in the city, given a profile of its skyline.  

The city in profile is quite dull architecturally, featuring only box-shaped buildings. The skyline of a city on the horizon is somewhere between 1 and W units wide (1 <= W <= 1,000,000) and described using N (1 <= N <= 50,000) successive x and y coordinates (1 <= x <= W, 0 <= y <= 500,000), defining at what point the skyline changes to a certain height.  

An example skyline could be:  
.......................... 
.....XX.........XXX....... 
.XXX.XX.......XXXXXXX..... 
XXXXXXXXXX....XXXXXXXXXXXX
 

and would be encoded as (1,1), (2,2), (5,1), (6,3), (8,1), (11,0), (15,2), (17,3), (20,2), (22,1).  

This skyline requires a minimum of 6 buildings to form; below is one possible set of six buildings whose could create the skyline above:  

.......................... .......................... 
.....22.........333....... .....XX.........XXX....... 
.111.22.......XX333XX..... .XXX.XX.......5555555..... 
X111X22XXX....XX333XXXXXXX 4444444444....5555555XXXXX 

.......................... 
.....XX.........XXX....... 
.XXX.XX.......XXXXXXX..... 
XXXXXXXXXX....666666666666

Input

* Line 1: Two space separated integers: N and W  

* Lines 2..N+1: Two space separated integers, the x and y coordinate of a point where the skyline changes. The x coordinates are presented in strictly increasing order, and the first x coordinate will always be 1.

Output

* Line 1: The minimum number of buildings to create the described skyline.

Sample Input

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1

Sample Output

6

Hint

INPUT DETAILS:  
The case mentioned above

Source


题意:以坐标的形式给出一张图,表示一些楼房的正视图,求出楼房的最少个数。

思路:维护一个递增的单调队列,如果当队尾元素大于要入队的元素,那么此时该队尾元素可能延伸的位置就已经确定了,因为比它低的点的正视图 不能再被该队尾元素覆盖 否则其坐标不会比其低,然后每tail--一次,就增加一个楼;

代码:

#include<cstdio>
#include<cmath>
#include<string>
#include<cstring>
#include<queue>
#include<algorithm>
#include<iostream>
#include<cstring>
#define maxn 50010
using namespace std;
int y[maxn],n,w,x;
int que[maxn];
int main()
{
    ios::sync_with_stdio(false);
    int tail=0;
    cin>>n>>w;
    for(int i=1;i<=n;i++){cin>>x>>y[i];}
    int ans=0;
    y[0]=y[n+1]=0;
    for(int i=1;i<=n+1;i++)  //注意,这里是到n+1。。。wa了好几次。。。
    {
        while(tail && y[que[tail]] > y[i]) { tail--; ans++; }
        if(y[que[tail]]!=y[i])
        {
            tail++;
            que[tail]=i;
        }
    }
    cout<<ans<<endl;
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值