City Skyline(POJ-3044)

Problem Description

The best part of the day for Farmer John's cows is when the sun sets. They can see the skyline of the distant city. Bessie wonders how many buildings the city has. Write a program that assists the cows in calculating the minimum number of buildings in the city, given a profile of its skyline. 

The city in profile is quite dull architecturally, featuring only box-shaped buildings. The skyline of a city on the horizon is somewhere between 1 and W units wide (1 <= W <= 1,000,000) and described using N (1 <= N <= 50,000) successive x and y coordinates (1 <= x <= W, 0 <= y <= 500,000), defining at what point the skyline changes to a certain height. 

An example skyline could be: 
.......................... 
.....XX.........XXX....... 
.XXX.XX.......XXXXXXX..... 
XXXXXXXXXX....XXXXXXXXXXXX 

and would be encoded as (1,1), (2,2), (5,1), (6,3), (8,1), (11,0), (15,2), (17,3), (20,2), (22,1). 

This skyline requires a minimum of 6 buildings to form; below is one possible set of six buildings whose could create the skyline above: 

.......................... .......................... 
.....22.........333....... .....XX.........XXX....... 
.111.22.......XX333XX..... .XXX.XX.......5555555..... 
X111X22XXX....XX333XXXXXXX 4444444444....5555555XXXXX .......................... 
.....XX.........XXX....... 
.XXX.XX.......XXXXXXX..... 
XXXXXXXXXX....666666666666

Input

* Line 1: Two space separated integers: N and W 

* Lines 2..N+1: Two space separated integers, the x and y coordinate of a point where the skyline changes. The x coordinates are presented in strictly increasing order, and the first x coordinate will always be 1.

Output

* Line 1: The minimum number of buildings to create the described skyline.

Sample Input

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1

Sample Output

6

题意:用坐标的形式给出一些楼房的高度,求楼房最小个数。

思路:

读了半天题图还是看不懂,看了下题解,原来给的是楼房正视图每次高度改变时的坐标,实质上是维护一个递增的单调栈。

先将 0 压栈,然后遍历所有高度,如果栈顶元素大于当前高度,说明栈顶元素所代表的高度的楼找到了,楼数+1,不断弹出栈顶元素,直到栈顶元素小于当前高度,如果栈顶元素小于当前高度的话,就将当前高度压栈,继续向下寻找。

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 100001
#define MOD 123
#define E 1e-6
using namespace std;
int x[N],y[N];
int main()
{
    int n,w;
    scanf("%d%d",&n,&w);

    for(int i=1;i<=n;i++)
        scanf("%d%d",&x[i],&y[i]);
    y[n+1]=0;

    stack<int> s;
    int cnt=0;
    s.push(0);
    for(int i=1;i<=n+1;i++)
    {
        while(!s.empty()&&s.top()>y[i])
        {
            s.pop();
            cnt++;
        }
        if(y[i]!=s.top())
            s.push(y[i]);
    }

    printf("%d\n",cnt);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值