HDU4632:Palindrome subsequence(区间DP+容斥原理)

Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi  = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
 
 
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
 
 
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960

普及:

容斥原理: 计数时,必须注意没有重复,没有遗漏。为了使重叠部分不被重复计算,人们研究出一种新的计数方法,这种方法的基本思想是:先不考虑重叠的情况,把包含于某内容中的所有对象的数目先计算出来,然后再把计数时重复计算的数目排斥出去,使得计算的结果既无遗漏又无重复,这种计数的方法称为容斥原理。

题意:

题意是询问一个字符串中回文子序列的个数。

用dp[i][j]表示这一段里有多少个回文串,那首先dp[i][j]=dp[i+1][j]+dp[i][j-1],但是dp[i+1][j]和dp[i][j-1]可能有公共部分,所以要减去dp[i+1][j-1]。

代码:

#include <stdio.h> 
#include <string.h>  
#include <algorithm>  
using namespace std;  
  
const int mod = 10007;  
char str[1005];  
int dp[1005][1005];  
  
int main()  
{  
    int t,i,j,k,len,cas = 1;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%s",str);  
        len = strlen(str);  
        for(i = 0; i<len; i++)  
            dp[i][i] = 1;//单个字符肯定是一个回文子串  
        for(i = 1; i<len; i++)  //枚举终点
        {  
            for(j = i-1; j>=0; j--)  //枚举起点 ,这么枚举的原因是因为使字符串由小到大
            {  
                dp[j][i] = (dp[j+1][i]+dp[j][i-1]-dp[j+1][i-1]+mod)%mod;//j~i的区间的回文数是j+1~i与j~i-1区间回文数的和,但是要注意这里会有重复的,运用的是容斥原理,注意此处算出的dp[i][j]只包含i或者j的,这里没有对同时包含i和j的情况的计算。非常重要的一点,也是难理解的一点  
                if(str[i] == str[j])   //如果两边相等了,那么加上dp[j+1][i-1]的原因,是在两边同时加上相同的相同的字符串,加1的原因是因为加上1个相同的字符串"str[i]str[j]".
                    dp[j][i] = (dp[j][i]+dp[j+1][i-1]+1+mod)%mod;//如果区间两头是相等的,则要加上dp[j+1][i-1]+1,因为首尾是可以组成一个回文子串的,而且首尾可以与中间任何一个回文子串组成新的回文子串  
            }  
        }  
        printf("Case %d: %d\n",cas++,dp[0][len-1]);  
    }  
  
    return 0;  
}  




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值