ACM Computer Factory (最大流+Dinic+输出路径+拆点)

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of Pnumbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,PDi,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input
Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1
Sample Output
Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0
Hint
Bold texts appearing in the sample sections are informative and do not form part of the actual data.

题意:组装电脑,p个组件,n个机器。0代表没有该组件,1代表一定有该组件,2代表可以有也可以没有。要求找出从初始什么组件都没有的电脑,组装成完整的电脑的最多的流水线。输出组装数,和机器连接方式。

思路:(纠结了一个晚上啊啊啊啊)

  1. 设置一个超级源点S和一个超级汇点 
    超级源点向所有源点连一条容量为INF的边 
    所有汇点想超级汇点连一条容量为INF的边

  2. 将每个机器i拆分成两个节点i和i+n, 连一条容量为这台机器效率的边

  3. 如果机器i的输出与机器j的输入匹配, 连一条i+n向j, 容量为inf的边

代码:

#include<map>
#include<vector>
#include<queue>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#define maxn 400
#define PI acos(-1.0)
#define INF 1e9  
using namespace std;
typedef long long ll;

struct Edge{
	 int to, cap, rev, flow;
    Edge(int To, int Cap, int Rev, int Flow):to(To), cap(Cap), rev(Rev), flow(Flow){}
}; 
vector<Edge>G[maxn];  //与模板不同,直接用向量存边
struct Dinic{
	int n,m,s,t;
	//vector<int>G[maxn];
	bool vis[maxn];
	int d[maxn];
	int cur[maxn];
	
	void init(int s,int t){
		this->s=s;
		this->t=t;
		for(int i=0;i<maxn;i++){
			G[i].clear();
		}
	}
	
	void AddEdge(int from,int to,int cap){
	    G[from].push_back(Edge(to, cap, int(G[to].size()), 0));
        G[to].push_back(Edge(from, 0, int(G[from].size()-1), 0));
	}
	bool BFS(){
		memset(vis,0,sizeof(vis));
		queue<int>Q;
		Q.push(s);
		d[s] = 0;
		vis[s]=1;
		while(!Q.empty()){
			int x=Q.front();
			Q.pop();
			for(int i=0;i<G[x].size();i++){
				Edge &e=G[x][i];
				if(!vis[e.to]&&e.cap>e.flow){
					vis[e.to]=1;
					d[e.to]=d[x]+1;
					Q.push(e.to);
				}
			}
		}
		return vis[t];
	}
	
	int DFS(int x,int a) {
		if(x==t||a==0) return a;
		int flow=0,f;
		for(int& i=cur[x];i<G[x].size();i++){
			Edge& e =G[x][i];
			
			if(d[x]+1==d[e.to]&&(f=DFS(e.to,min(a,e.cap-e.flow)))>0){
				e.flow+=f;
				G[e.to][e.rev].flow-=f;
				flow+=f;
				a-=f;
				if(a==0) break;
			}
		}
		return flow;
	}
	
	int Maxflow(){
		int flow=0;
		while(BFS()){
			memset(cur,0,sizeof(cur));
			flow+=DFS(s,INF);
		}
		return flow;
	}
	/*void print(){ 
	    
		for(int i=n+1;i<t;++i){
			for(int j=0;j<G[i].size();j){
				
				 Edge& e=edges[G[i][j]];
				 if(e.flow>0 && e.to <=n){
				 	path[ans][0]=e.from;
				 	path[ans][1]=e.to;
				 	path[ans][2]=e.flow;
				 	++ans;
				 }
			}
		} 
		printf(" %d\n",ans);
		for(int i=0;i<ans;i++)  
		printf("%d %d %d\n",path[i][0],path[i][1],path[i][2]);
	}
	*/
}DC; 

struct machine{
	
	int w,in[15],out[15];
	
}ma[maxn];

int p,q,n;

int ans=0; 
int path[1000][3];
int main()
{
	while(scanf("%d%d",&p,&n)==2){
		int src=0;
		int dst=2*n+1;
		DC.init(src,dst);
		for(int i=1;i<=n;++i){
			scanf("%d",&q);
			ma[i].w=q;
			bool flag=1;
			for(int j=0;j<p;j++){
				scanf("%d",&ma[i].in[j]);
				if(ma[i].in[j]==1) flag=0;
			}
			if(flag) DC.AddEdge(src,i,INF);
			flag=1;
			for(int j=0;j<p;j++){
				scanf("%d",&ma[i].out[j]);
				if(ma[i].out[j]==0) flag=0;
				
			}
			if(flag) DC.AddEdge(i+n,dst,INF);
		}
		for(int i=1;i<=n;i++){
			DC.AddEdge(i,i+n,ma[i].w);
			for(int j=1;j<=n;j++){
				if(i==j) continue;
				bool flag=1;
				for(int k=0;k<p;k++){
					if(ma[j].in[k]!=2 && ma[i].out[k]!=ma[j].in[k]){
						flag=0;
						break;
					}
				}
				if(flag) DC.AddEdge(i+n,j,INF);
			}
		}
		int flow=DC.Maxflow();
		ans=0;
		 for(int i=n+1; i<dst; ++i)
        {
            for(int j=0; j<(int)G[i].size(); ++j)
            {
                Edge &e = G[i][j];
                if(e.flow > 0 && e.to <= n)
                {
                    path[ans][0] = i-n;
                    path[ans][1] = e.to;
                    path[ans][2] = e.flow;
                    ++ans;
                }
            }
        }

        printf("%d %d\n", flow, ans);
        for(int i=0; i<ans; ++i) printf("%d %d %d\n", path[i][0], path[i][1], path[i][2]);
	
	}
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值