Control (最大流+Dinic+拆点)

You, the head of Department of Security, recently received a top-secret information that a group of terrorists is planning to transport some WMD  1 from one city (the source) to another one (the destination). You know their date, source and destination, and they are using the highway network. 
  The highway network consists of bidirectional highways, connecting two distinct city. A vehicle can only enter/exit the highway network at cities only. 
  You may locate some SA (special agents) in some selected cities, so that when the terrorists enter a city under observation (that is, SA is in this city), they would be caught immediately. 
  It is possible to locate SA in all cities, but since controlling a city with SA may cost your department a certain amount of money, which might vary from city to city, and your budget might not be able to bear the full cost of controlling all cities, you must identify a set of cities, that: 
  * all traffic of the terrorists must pass at least one city of the set. 
  * sum of cost of controlling all cities in the set is minimal. 
  You may assume that it is always possible to get from source of the terrorists to their destination. 
------------------------------------------------------------ 
1 Weapon of Mass Destruction
Input
  There are several test cases. 
  The first line of a single test case contains two integer N and M ( 2 <= N <= 200; 1 <= M <= 20000), the number of cities and the number of highways. Cities are numbered from 1 to N. 
  The second line contains two integer S,D ( 1 <= S,D <= N), the number of the source and the number of the destination. 
  The following N lines contains costs. Of these lines the ith one contains exactly one integer, the cost of locating SA in the ith city to put it under observation. You may assume that the cost is positive and not exceeding 10  7
  The followingM lines tells you about highway network. Each of these lines contains two integers A and B, indicating a bidirectional highway between A and B. 
  Please process until EOF (End Of File). 
Output
  For each test case you should output exactly one line, containing one integer, the sum of cost of your selected set. 
  See samples for detailed information.
Sample Input
5 6
5 3
5
2
3
4
12
1 5
5 4
2 3
2 4
4 3
2 1
Sample Output
3

题意:有N个城市,现在城市S出现了一群人,他们想运送一些炸弹到D城市,警方采取封锁城市的办法来阻断暴徒,不过封锁城市是需要花费一定代价的,求阻断暴徒从S城市到达D城市的最小需要花费的代价。

思路:
一开始当成了最小费用最大流问题,其实还是最大流问题,建图:
将每个城市点拆开i和i’,连接两点权值就是花费;

可连每个城市和每个城市之间的权值为INF,跑一边最大流即可。

代码:

#include<map>
#include<vector>
#include<queue>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#define maxn 40000
#define PI acos(-1.0)
#define INF 1e9  
using namespace std;
typedef long long ll;

struct Edge{
	int from,to,cap,flow;
	Edge(){}
	Edge(int f,int t,int c,int fl):from(f),to(t),cap(c),flow(fl){}
}; 

struct Dinic{
	int n,m,s,t;
	vector<Edge>edges;
	vector<int>G[maxn];
	bool vis[maxn];
	int d[maxn];
	int cur[maxn];
	
	void init(int s,int t){
		this->s=s;
		this->t=t;
		for(int i=0;i<maxn;i++){
			G[i].clear();
		}
		edges.clear();
	}
	
	void AddEdge(int from,int to,int cap){
		edges.push_back((Edge){from,to,cap,0});
		edges.push_back((Edge){to,from,0,0}) ;
		m=edges.size();
		G[from].push_back(m-2);
		G[to].push_back(m-1);
	}
	
	bool BFS(){
		memset(vis,0,sizeof(vis));
		queue<int>Q;
		Q.push(s);
		d[s] = 0;
		vis[s]=1;
		while(!Q.empty()){
			int x=Q.front();
			Q.pop();
			for(int i=0;i<G[x].size();i++){
				Edge &e=edges[G[x][i]];
				if(!vis[e.to]&&e.cap>e.flow){
					vis[e.to]=1;
					d[e.to]=d[x]+1;
					Q.push(e.to);
				}
			}
		}
		return vis[t]	;
	}
	
	int DFS(int x,int a) {
		if(x==t||a==0) return a;
		int flow=0,f;
		for(int& i=cur[x];i<G[x].size();i++){
			Edge& e =edges[G[x][i]];
			
			if(d[x]+1==d[e.to]&&(f=DFS(e.to,min(a,e.cap-e.flow)))>0){
				e.flow+=f;
				edges[G[x][i]^1].flow-=f;
				flow+=f;
				a-=f;
				if(a==0) break;
			}
		}
		return flow;
	}
	
	int Maxflow(){
		int flow=0;
		while(BFS()){
			memset(cur,0,sizeof(cur));
			flow+=DFS(s,INF);
		}
		return flow;
	}
}DC; 
int n,m;
int s,t;
int main()
{

	 while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        int i;  
        int w;
        scanf("%d%d",&s,&t);  
        t=t+n;
        DC.init(s,t);
        
        for(i=1;i<=n;i++)  
        {  
            scanf("%d",&w);  
            DC.AddEdge(i,i+n,w);  
        }  
        
        int a,b;  
        
        for(i=1;i<=m;i++)  
        {  
            scanf("%d%d",&a,&b);  
            DC.AddEdge(a+n,b,INF);  
            DC.AddEdge(b+n,a,INF);  
        }
        int flow=DC.Maxflow();
        printf("%d\n",flow);
    }  
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值