POJ 3279 Fliptile(反转)

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6081 Accepted: 2308

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

 
 
4 4
1 0 0 1
0 1 1 0
1 0 0 1
0 1 1 0

Sample Output

 
 
0 0 0 0
1 0 0 1
0 0 0 0
1 0 0 1


题意:有一个n*m的格子,每个格子都有黑白两面(0表示白色,1表示黑色)。我们需要把所有的格子都反转成黑色,每反转一个格子,它上下左右的格子都会跟着反转。请求出用最小步数完成反转时每个格子反转的次数。有多个解时,输出字典序最小的一组。

题解:我们先指定最上面一行的翻转方法。此时能够反转(1,1)的只有(2,1)了,所以直接判断(2,1)是否需要翻转。直到确定第二行,依次判断到最后一行。最后判断最后一行是否全为白色来确定当前方案是否可行。  像这样的方法,我们枚举这一行所有的情况,共2^m种可能。 时间复杂度为O(n*m*2^m)。

代码如下:

#include<cstdio>
#include<cstring>
int n,m,map[20][20];
int opt[20][20];//保存最优解 
int flip[20][20];//保存中间结果 
int dir[5][2]={{1,0},{-1,0},{0,0},{0,-1},{0,1}};

int judge(int x,int y)//查询(x,y)的颜色 
{
	int i,c=map[x][y];
	for(i=0;i<5;++i)
	{
		int x2=x+dir[i][0],y2=y+dir[i][1];
		if(0<=x2&&x2<n&&0<=y2&&y2<m)
			c+=flip[x2][y2];
	}
	return c%2;
}

int calc()
{
	int i,j,res;
	for(i=1;i<n;++i)
	{
		for(j=0;j<m;++j)
		{
			if(judge(i-1,j)!=0)//上方格子是黑色,必须必须反转(i,j)号格子 
				flip[i][j]=1; 
		}
	}
	for(i=0;i<m;++i)//判断最后一行是否全白 
	{
		if(judge(n-1,i)!=0)//当前方案不行 
			return -1;
	}
	res=0;
	for(i=0;i<n;++i)
	{
		for(j=0;j<m;++j)
		{
			res+=flip[i][j];//统计当前方案的反转次数 
		}
	}
	return res;
}

int main()
{
	int i,j,ans,num;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<m;++j)
				scanf("%d",&map[i][j]);
		}
		ans=-1;
		//按照字典序尝试第一行所有的可能性,方案为2^m种 
		for(i=0;i< 1<<m;++i)
		{
			memset(flip,0,sizeof(flip));
			for(j=0;j<m;++j)
				flip[0][m-j-1]=i>>j&1;
			num=calc();
			if(num>=0&&(ans<0||ans>num))
			{
				ans=num;
				memcpy(opt,flip,sizeof(flip));//把flip数组复制给opt数组 
			}
		}
		if(ans==-1)
			printf("IMPOSSIBLE\n");
		else
		{
			for(i=0;i<n;++i)
			{
				for(j=0;j<m;++j)
				{
					if(j==m-1)
						printf("%d\n",opt[i][j]);
					else
						printf("%d ",opt[i][j]);
				}
			}
		}
	}
	return 0;
}




  • 1
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值