POJ 2528 Mayor's posters-------线段树之离散化

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 76634 Accepted: 22079

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题意:可以张贴很多海报,并且可以将一张海报覆盖在另一张的上面,求在这个区间中可以看见的所有海报的数目。这道题的数据很大,所以要用到离散化。下面我们来浅谈离散化。

就题目中的例子来说:[1,4]、[2,6]、[8,10]、[3,4]、[7,10]

第一步:从小到大排序:1、2、3、4、4、6、7、8、10、10

第二步:除去重复元素:1、2、3、4、6、7、8、10

第三步:对应编号:       1、2、3、4、5、6、7、8

则该例子最终离散化后得到的区间为:[1,4]、[2,5]、[7,8]、[3,4]、[6,8]

也就是说本来应建立长度为10的数组,现在已经压缩为8了,这大大节省了程序空间。

 

#include<iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
#define clc(a,b) memset(a,b,sizeof(a))
using namespace std;
#define LL long long
const int maxn=100000;
int vis[maxn<<2];//统计海报
int ans=0;//记录可见的海报数
int x[maxn];//存储数据离散化的数组
int hashh[maxn<<2];//记录是否海报被计算过
struct node
{
    int l,r;
} q[maxn];//存储海报的数组

void pushdown(int rt)
{
    if(vis[rt]!=-1)//若该区间已经被访问过了,并且这个区间有海报,就要将这个区间的海报颜色更新到其他孩子节点,并将该区间清空,这才算是覆盖
    {
        vis[rt<<1]=vis[rt<<1|1]=vis[rt];
        vis[rt]=-1;
    }
}

void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        vis[rt]=c;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,l,m,rt<<1);
    if(R>m) update(L,R,c,m+1,r,rt<<1|1);
}

void query(int l,int r,int rt)
{
    if(vis[rt]!=-1)//如果这个区间有海报则准备计数
    {
        if(!hashh[vis[rt]])//如果没有被统计过就ans++
            ans++;
        hashh[vis[rt]]=1;
        return;
    }
    if(l==r)
        return;
    int m=(l+r)>>1;
    query(l,m,rt<<1);
    query(m+1,r,rt<<1|1);
}

int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&q[i].l,&q[i].r);
            x[cnt++]=q[i].l,x[cnt++]=q[i].r;
        }
        sort(x,x+cnt);//离散化的第一步排序
        int m;
        m = unique(x, x + cnt) - x;//第二步除重       
        clc(vis,-1);
        for(int i=0; i<n; i++)
        {
            int l=lower_bound(x,x+m,q[i].l)-x;//第三步形成离散化后的区间
            int r=lower_bound(x,x+m,q[i].r)-x;
            update(l,r,i,0,m-1,1);
        }
        clc(hashh,0);
        ans=0;
        query(0,m-1,1);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值