POJ 3264 Balanced Lineup-----线段树

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 63534 Accepted: 29652
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:求一个区间内的最大值与最小值的差。这道题直接套线段树的模板,只用查询还不需要更新就可以AC,但是要查两次,一次最大值,一次最小值,然后相减得到最终答案。但是一定要注意输入输出用c的stdio形式,不要用c++的iosteam形式,不然就会一直出现Time Limit Exceeded错误!!!

#include <iostream>
#include <stdio.h>
#define maxn 50005
#define inf 1000010
using namespace std;
int MAX[maxn<<2];
int MIN[maxn<<2];
int a[maxn<<2];
void pushup(int rt)
{
    MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
    MIN[rt]=min(MIN[rt<<1],MIN[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&MAX[rt]);
        MIN[rt]=MAX[rt];
        return ;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
int query1(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        return MAX[rt];
    }
    int m=(l+r)>>1;
    int maxm=0;
    if(L<=m)maxm=max(maxm,query1(L,R,l,m,rt<<1));
    if(R>m)maxm=max(maxm,query1(L,R,m+1,r,rt<<1|1));
    return maxm;
}
int query2(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        return MIN[rt];
    }
    int m=(l+r)>>1;
    int minm=inf;
    if(L<=m)minm=min(minm,query2(L,R,l,m,rt<<1));
    if(R>m)minm=min(minm,query2(L,R,m+1,r,rt<<1|1));
    return minm;
}
int main()
{
    int n,q,x,y;
    scanf("%d%d",&n,&q);
    build(1,n,1);
    for(int i=0;i<q;i++)
    {
        scanf("%d%d",&x,&y);
        printf("%d\n",query1(x,y,1,n,1)-query2(x,y,1,n,1));
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值