POJ - 3273(二分)

Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

题意:给出n天的花费,分m次给,每次给的钱可是一天的花费或者连续几天的花费。最后使每次给的钱的最大值最小化,也就是每次给的钱尽可能的少,求m次中的最大值。

思路:二分答案,最好情况为m==n,最坏情况m=1。所以二分范围为max(daycost[i])~sum。

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>
#include <functional>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
const int MAXN=1e9+10;
const int MAX=1e6+10;
ll num[MAX],maxx,sum;
int n,m;

bool juge(ll mid){
    ll count=0;
    int cnt=1;
    for(int i=1;i<=n;i++){
        count+=num[i];
        if(count>mid){
            count=0;
            i--;
            cnt++;
        }
    }
    if(cnt<=m)
        return 1;
    else
        return 0;
}

int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    #endif
    while(~scanf("%d%d",&n,&m)){
        sum=0;maxx=-1;
        for(int i=1;i<=n;i++){
            scanf("%lld",&num[i]);
            maxx=max(maxx,num[i]);
            sum+=num[i];
        }
        ll l=maxx,r=sum,mid;    //二分答案
        while(l<r){
            mid=(l+r)/2;
            if(juge(mid))
                r=mid-1;//mid太大
            else
                l=mid+1;//mid太小
        }
        cout<<l<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值