POJ-2663:Tri Tiling

http://poj.org/problem?id=2663

题目

Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes?
Here is a sample tiling of a 3x12 rectangle.
在这里插入图片描述

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.
Output

For each test case, output one integer number giving the number of possible tilings.
Sample Input

2
8
12
-1
Sample Output

3
153
2131

思路

推导出公式,因为输入n不大,可以提前求出所有结果保存下来。 手写的推导过程,写的不太整齐-_-||。注意本题n=0时需要输出1。
请添加图片描述

代码

#include <iostream>

int main() {
	const int MAX_COUNT = 31;
	int result[MAX_COUNT];
	memset(result, 0, sizeof(result));
	result[0] = 1;
	int cum = 0;
	for (int i = 2; i < MAX_COUNT; i += 2) {
		result[i] = 3 * result[i - 2];
		result[i] += cum * 2;
		cum += result[i - 2];
		//printf("%d\n", result[i]);
	}
	int n = 0;
	while (scanf("%d", &n) != EOF && n != -1) {
		printf("%d\n", result[n]);
	}

	return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

superbin

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值