HDU 1143 Tri Tiling

135 篇文章 0 订阅
44 篇文章 0 订阅
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.


 

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.
 

Output
For each test case, output one integer number giving the number of possible tilings.
 

Sample Input
  
  
2 8 12 -1
 

Sample Output
  
  
3 153 2131
 

可以说是个DP  之前做过两行的 这个三行的做法也差不多 
首先 奇数都是0
然后2的时候为3  4的时候,如果不能拆分成2个2的话 就只有2种拆法  6的时候不折成3个2或者1个2 1个4的话 也有两种拆法 8也是这样…………
所以可以算到公式 
an=3*an-2+2*(an-4+an-6....)
进一步化简可以得  a[i]=4*a[i-2]-a[i-4];
#include <stdio.h>

int main()
{
    int a[40]={0},n,i;
    a[0]=1;a[2]=3;
    for(i=4;i<32;i+=2)
        a[i]=4*a[i-2]-a[i-4];
    while(~scanf("%d",&n)&&n!=-1)
        printf("%d\n",a[n]);
    return 33;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值