Complete Binary Tree

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题目大意:
判断一棵树是不是完全二叉树,是的话输出YES和最后一个结点,否则输出NO和根节点。

王道书上同样有相同的一道算法题,算法的思路都一样,只是王道书上要求的树是用二叉链表存储结构存储的。

思路:
采用层次遍历算法,将所有结点加入队列(包括空结点)。遇到空结点时,看其后是否有非空结点。若有,则二叉树不是完全二叉树。

#include<bits/stdc++.h>
using namespace std;
struct Complete_Binary_Tree
{
    int data;
    int lchild, rchild;
}node[25];
int n;
bool visited[25] = {false};
int turn(string s) {
    int sum = 0;
    for(auto &i:s) sum = sum * 10 + (i - '0');
    return sum;
}
int build_tree() {
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        string left, right;
        cin >> left >> right;
        node[i].data = i;
        if(left == "-") node[i].lchild = -1;
        else {
            node[i].lchild = turn(left);
            visited[node[i].lchild] = true;
        }
        if(right == "-") node[i].rchild = -1;
        else {
            node[i].rchild = turn(right);
            visited[node[i].rchild] = true;
        }
    }
    for(int i = 0; i < n; i++) {
        if(!visited[i]) return i;//返回根节点
    }
}
int last_node = 0;
bool iscomplete(int root) {
    queue<int>q;
    if(n == 0) return true; // 空树为满二叉树
    q.push(root);
    while (!q.empty())
    {
        int top = q.front();
        q.pop();
        if(top != -1) last_node = top;
        if(top != -1) {
            q.push(node[top].lchild);
            q.push(node[top].rchild);
        } else { // 结点为空,检查其后是否有非空结点
            while(!q.empty()) {
                int temp = q.front();
                q.pop();
                if(temp != -1) return false; // 结点非空,则二叉树为非完全二叉树
            }
        }
    }
    return true;
}
int main() {
    int root = build_tree();
    // for(int i = 0; i < n; i++) cout << node[i].lchild << " " << node[i].rchild << endl;
    // cout << root << endl;
    if(iscomplete(root)) printf("YES %d", last_node);
    else printf("NO %d", root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值