1097. Deduplication on a Linked List

1097. Deduplication on a Linked List (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
好吧,错在了一个很隐秘地方,while()循环的条件要注意,并不是n次,而是找到-1为止,理论上是一样的,可是我猜可能测试数据里有不是链表的数据。
我想起来在网易云课堂上听姥姥的课的时候她提到过,原来就是这个题,改了好久......
期间优化的把用set记录改成了数组记录出现,这样节省了时间增加空间,其实之前写的只用存remove即可,另外一个在遍历表时就可以输出了,后来被改掉了。如果remove表是空的,就不用输出。
#include<iostream>
#include<vector>
#include<algorithm>
#include<set>
#include<cmath>

using namespace std;

vector<int>mov;
vector<int>ans;
int c[100000];
int val[100000];

int main()
{
	int root,n;
	vector<int>num(10001);
	cin>>root>>n;
	for(int i=0;i<n;++i)
	{
		int id,key,next;
		cin>>id>>key>>next;
		c[id]=next;
		val[id]=key;
	}
	int cnt=n;
	//while(cnt--)
	while(root!=-1)
	{
		if(num[abs(val[root])]==0)
		{
			num[abs(val[root])]++;
			ans.push_back(root);
		}
		else
			mov.push_back(root);
		root=c[root];
	}
	for(int i=0;i<ans.size();++i)
	{
		if(i+1<ans.size())
			printf("%05d %d %05d\n",ans[i],val[ans[i]],ans[i+1]);
		else
			printf("%05d %d -1\n",ans[i],val[ans[i]]);
	}
	if(!mov.empty())
	{
		for(int i=0;i<mov.size();++i)
		{
			if(i+1<mov.size())
				printf("%05d %d %05d\n",mov[i],val[mov[i]],mov[i+1]);
			else
				printf("%05d %d -1\n",mov[i],val[mov[i]]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值