ZOJ 3203 Light Bulb 三分查找


二分法作为分治中最常见的方法,适用于单调函数,逼近求解某点的值。但当函数是凸性函数时,二分法就无法适用,这时三分法就可以“大显身手”~

 三分查找

如图,类似二分的定义Left和Right,mid = (Left + Right) / 2,midmid = (mid + Right) / 2;

如果mid靠近极值点,则Right = midmid;否则(即midmid靠近极值点),则Left = mid;

模版如下:

int Cale(int  )

{

}

int Solve(int left ,int right)

{

int mid,midmid;

while(left<right)

{

mid=(left+right)/2;

midmid=(mid+right)/2;

if(Cale(mid) > Cale(midmid)) right=midmid;///假设求最大值

else left=mid;

}

return left;

}


Light Bulb

Time Limit: 1 Second       Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000



# include<stdio.h>
# define EP 1e-10
double H,h,d,ans;
double Cale(double x)
{
    if(x<=ans) 
       return h*x/(H-h);
    return d-x+(d*h+H*x-H*d)/x;
}
double Solve(double left,double right)
{
    double mid;
    double midmid;
    while(left + EP < right)
    {
        mid=(left+right)/2;
        midmid=(mid+right)/2;
        if( Cale(mid) > Cale(midmid) )
           right=midmid;
        else 
           left=mid;
    }
    return left;
}
int main()
{
   // printf("%.10lf\n",EP); 
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&H,&h,&d);
        ans=d-d*h/H;
      //  printf("%lf\n",ans);
        printf("%.3lf\n",Cale(Solve(0,d)));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值