hdojGirl Love Value 2670 (01背包)

Girl Love Value

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 787    Accepted Submission(s): 442


Problem Description
Love in college is a happy thing but always have so many pity boys or girls can not find it.
Now a chance is coming for lots of single boys. The Most beautiful and lovely and intelligent girl in HDU,named Kiki want to choose K single boys to travel Jolmo Lungma. You may ask one girls and K boys is not a interesting thing to K boys. But you may not know Kiki have a lot of friends which all are beautiful girl!!!!. Now you must be sure how wonderful things it is if you be choose by Kiki.



Problem is coming, n single boys want to go to travel with Kiki. But Kiki only choose K from them. Kiki every day will choose one single boy, so after K days the choosing will be end. Each boys have a Love value (Li) to Kiki, and also have a other value (Bi), if one boy can not be choose by Kiki his Love value will decrease Bi every day.
Kiki must choose K boys, so she want the total Love value maximum.

Input
The input contains multiple test cases.
First line give the integer n,K (1<=K<=n<=1000)
Second line give n integer Li (Li <= 100000).
Last line give n integer Bi.(Bi<=1000)

Output
Output only one integer about the maximum total Love value Kiki can get by choose K boys.

Sample Input
  
  
3 3 10 20 30 4 5 6 4 3 20 30 40 50 2 7 6 5

Sample Output
  
  
47 104
/* 题意:一个女神要从n个男生中选m个男生,求最大的爱慕值。 给你两个数n,m,分别代表有n个男生,女神要选m个。 接下来一行输入n个数表示每个男生对这个女神的初始爱慕值li, 再接着一行输入n个数表示每个男生对这个女神的失望值bi(如果今天女神不选他, 他对这个女神的爱慕值就会减少bi。。。) 思路: 知道题意后解题就不是很难了。就是一个单纯的01背包 */
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define N 1010
using namespace std;
struct zz
{
	int li;
	int bi;
}q[N];
int dp[N];
int cmp(zz a,zz b)
{
	return a.bi>b.bi;
}
int main()
{
	int n,m,i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
			scanf("%d",&q[i].li);
		for(i=0;i<n;i++)
			scanf("%d",&q[i].bi);
		sort(q,q+n,cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=m;j>=1;j--)
			{
				dp[j]=max(dp[j],dp[j-1]+q[i].li-(j-1)*q[i].bi);
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值