HDU 5461 Largest Point

Problem Description
Given the sequence A with n integers t1,t2,,tn . Given the integral coefficients a and b . The fact that select two elements ti and tj of A and ij to maximize the value of at2i+btj , becomes the largest point.
 

Input
An positive integer T , indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) and b (0|b|106) . The second line contains n integers t1,t2,,tn where 0|ti|106 for 1in .

The sum of n for all cases would not be larger than 5×106 .
 

Output
The output contains exactly T lines.
For each test case, you should output the maximum value of at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5467  5466  5465  5464  5463 

 

开个结构体标下号,避免重复。然后分四种情况讨论。

//#pragma commmpnt(linkmpr, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
using namespace std;
typedef long long ll;
const int M = 5000010;
const int INF =0x3f3f3f3f;
struct node
{
    ll ans;
    int num;
} s1[M],s2[M];
bool cmp(node a,node b)
{
    return a.ans<b.ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    int dd=0;
    while(t--)
    {
        int n,a,b;
        scanf("%d%d%d",&n,&a,&b);
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&s2[i].ans);
            s1[i].ans=s2[i].ans*s2[i].ans;
            s1[i].num=s2[i].num=i;
        }
        sort(s1,s1+n,cmp);
        sort(s2,s2+n,cmp);
        ll res=0;
        //  int flag=0;
        if(a>=0 &&b>=0)
        {
            if(s1[n-1].num==s2[n-1].num)
                res=max(a*s1[n-1].ans+b*s2[n-2].ans,a*s1[n-2].ans+b*s2[n-1].ans);
            else
                res=a*s1[n-1].ans+b*s2[n-1].ans;
        }
        else if(a>=0 &&b<=0)
        {
            if(s1[n-1].num==s2[0].num)
                res=max(a*s1[n-1].ans+b*s2[1].ans,a*s1[n-2].ans+b*s2[0].ans);
            else
                res=a*s1[n-1].ans+b*s2[0].ans;
        }
        else if(a<=0 &&b>=0)
        {
            if(s1[0].num==s2[n-1].num)
                res=max(a*s1[0].ans+b*s2[n-2].ans,a*s1[1].ans+b*s2[n-1].ans);
            else
                res=a*s1[0].ans+b*s2[n-1].ans;
        }
        else  if(a<=0 &&b<=0)
        {
            if(s1[0].num==s2[0].num)
                res=max(a*s1[0].ans+b*s2[1].ans,a*s1[1].ans+b*s2[0].ans);
            else
                res=a*s1[0].ans+b*s2[0].ans;
        }
        //   cout<<flag<<endl;
        printf("Case #%d: ",++dd);
        printf("%lld\n",res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值