HDU 5001 Walk

3 篇文章 0 订阅

Walk

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1049    Accepted Submission(s): 674
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input
  
  
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output
  
  
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5751  5750  5749  5748  5747 

 




题意:从任意一个点出发,走了d步,求不经过i点的概率。一个点到它能走的点的概率是都相同的。所以直接dp.

看代码。

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 105;
vector <int> edge[maxn];
double dp[105][10500];  //dp[j][d]表示不能经过i点走了d步到达j点的概率
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,D;
        scanf("%d %d %d",&n,&m,&D);
        for(int i = 0; i <= n+10; i++)
            edge[i].clear();
        for(int i = 1; i <= m; i++)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            edge[u].push_back(v);
            edge[v].push_back(u);
        }
        for(int i = 1; i <= n; i++)
        {
            memset(dp,0,sizeof(dp));
            for(int d = 1; d <= D+1; d++)
            {
                if(d==1)
                {
                    for(int j=1; j<=n; j++)  //初始化 一开始随机落在一个点上
                        if(j != i)
                            dp[j][d] = 1.0/n;
                }
                else
                {
                    for(int j = 1; j <= n; j++)
                    {
                        if(j != i)
                        {
                            for(int k = 0; k < (int)edge[j].size(); k++)
                            {
                                int x = edge[j][k];
                                if(x != i)
                                    dp[j][d] += dp[x][d-1]*1.0/edge[x].size();
                            }
                        }
                    }
                }
            }
            double res = 0;
            for(int j = 1; j <= n; j++)
                if(j != i)
                    res += dp[j][D+1];
            printf("%.12lf\n",res);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值