HDU 5000 Clone

Clone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1438    Accepted Submission(s): 668


Problem Description
After eating food from Chernobyl, DRD got a super power: he could clone himself right now! He used this power for several times. He found out that this power was not as perfect as he wanted. For example, some of the cloned objects were tall, while some were short; some of them were fat, and some were thin.

More evidence showed that for two clones A and B, if A was no worse than B in all fields, then B could not survive. More specifically, DRD used a vector v to represent each of his clones. The vector v has n dimensions, representing a clone having N abilities. For the i-th dimension, v[i] is an integer between 0 and T[i], where 0 is the worst and T[i] is the best. For two clones A and B, whose corresponding vectors were p and q, if for 1 <= i <= N, p[i] >= q[i], then B could not survive.

Now, as DRD's friend, ATM wants to know how many clones can survive at most.
 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case: The first line contains 1 integer N, 1 <= N <= 2000. The second line contains N integers indicating T[1], T[2], ..., T[N]. It guarantees that the sum of T[i] in each test case is no more than 2000 and 1 <= T[i].
 

Output
For each test case, output an integer representing the answer MOD 10^9 + 7.
 

Sample Input
  
  
2 1 5 2 8 6
 

Sample Output
  
  
1 7
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5751  5750  5749  5748  5747 

 


每个人有i种属性,每种属性的值为[0,t[i]]。当一个人的每种属性都小于另外一个人的每种属性,这个人就不能存活。

我们dp处理出每个人选了第i种属性时,总值为j。可见要想活的人数最多,他们的总值sum一定要是相等的。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define N 100050
typedef long long ll;
const int mod = 1e9+7;
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std ;
int T[2050];
int dp[2050][2050] ; // dp[i][j]表示选到第i种特征时,总值为j的种数
int main()
{
    int t ;
    scanf("%d",&t) ;
    while(t--)
    {
        int n ;
        scanf("%d",&n);
        int sum=0;
        for(int i=1 ; i<=n ; i++)
        {
            scanf("%d",&T[i]);
            sum+=T[i];
        }
        memset(dp,0,sizeof(dp)) ;
        for(int i=0 ; i<=T[1] ; i++)
            dp[1][i]=1 ;
        for(int i=2 ; i<=n ; i++)
        {
            for(int j=0 ; j<=2010; j++)
            {
                for(int k=0 ; k<=T[i] ; k++)
                {
                    if(j>=k)
                    {
                        dp[i][j]=(dp[i][j]+dp[i-1][j-k])%mod;
                        dp[i][j]%=mod;
                    }
                }
            }
        }
//        int ans=0;
//        for(int i=0; i<=2000; i++)
//            ans=max(ans,dp[n][i]);
        //      cout<<ans<<endl;
        cout<<dp[n][sum/2]<<endl;
        //  cout<<dp[n][sum/2+1]<<endl;
        //     cout<<dp[n][sum/2-1]<<endl;
        //    cout<<dp[n][0]<<endl;
        //    cout<<dp[n][sum]<<endl;
    }
    return 0 ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值