HDU 4268 Alice and Bob(贪心)

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3700    Accepted Submission(s): 1174


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

Source


   题意:两个人A,B分别有n个卡片,问A的卡片最多能覆盖住B的多少个卡片,其中A的一个卡片只能覆盖B的一个卡片,并且卡片不可以旋转。



#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<set>
using namespace std;
struct node
{
    int a;
    int b;
};
node q[200110],q1[200110];
__int64 vis[200110];
multiset<int>s;
std::multiset<int>::iterator it;
bool cmp(node a,node b)
{
    if(a.b==b.b)
    {
        return a.a<b.a;
    }
    return a.b<b.b;
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        s.clear();
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&q[i].a,&q[i].b);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&q1[i].a,&q1[i].b);
        }
        sort(q+1,q+1+n,cmp);
        sort(q1+1,q1+1+n,cmp);
        int x=1;
        int ans=0;
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=n; i++)
        {
            while(x<=n&&q1[x].b<=q[i].b)
            {
                s.insert(q1[x].a);
                x++;
            }
            if(s.size()==0)
            {
                continue;
            }
            it=s.lower_bound(q[i].a);
            if(*(it)==q[i].a)
            {
                    s.erase(it);
                    ans++;
            }
            else
            {
                if(it!=s.begin())
                {
                    --it;
                    s.erase(it);
                    ans++;

                }
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值