Tree

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

 

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

 

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

 

Sample Input 

 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

 

Sample Output 

 

1
3
255

思路:给出二叉树的中序遍历,后序遍历,构造二叉树,找最优方法为由根结点出发递归遍历直到叶子结点,将该路径的权和与目前的最优解取最大值赋给最优解变量。

#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;
const int maxn=10010;
int inv[maxn],pt[maxn],lt[maxn],rt[maxn];
int n;
int read_list(int *a)
{
	string line;
	if(!getline(cin,line))
	 return 0;
	 stringstream ss(line);
	 n=0;
	 int x;
	 while(ss>>x) a[n++]=x;
	 return n>0;
}
int build(int l1,int r1,int l2,int r2)
{
	if(l1>r1)
	 return 0;
    int root=pt[r2];
    int p=l1;
    while(inv[p]!=root)
      p++;
    int cnt=p-l1;
    lt[root]=build(l1,p-1,l2,l2+cnt-1);
    rt[root]=build(p+1,r1,l2+cnt,r2-1);
    return root;
}
int best_sum,best;
void dfs(int u,int sum)
{
	sum+=u;
	if(!lt[u]&&!rt[u])
	{
		if(sum<best_sum||(sum==best_sum&&u<best))
		{
			best=u;
			best_sum=sum;
		}
	 } 
	if(lt[u])
	  dfs(lt[u],sum);
	if(rt[u])
	  dfs(rt[u],sum);
}   
int main()
{
	while(read_list(inv))
	{
		read_list(pt);
		build(0,n-1,0,n-1);
		best_sum=1000000000;
		dfs(pt[n-1],0);
		cout<<best<<"\n";
	}
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的体育馆管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本体育馆管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此体育馆管理系统利用当下成熟完善的SpringBoot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的Mysql数据库进行程序开发。实现了用户在线选择试题并完成答题,在线查看考核分数。管理员管理收货地址管理、购物车管理、场地管理、场地订单管理、字典管理、赛事管理、赛事收藏管理、赛事评价管理、赛事订单管理、商品管理、商品收藏管理、商品评价管理、商品订单管理、用户管理、管理员管理等功能。体育馆管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:体育馆管理系统;SpringBoot框架;Mysql;自动化
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值