Shopping(map练习)

Problem Description

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.

Input

One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

Output

Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

题目大意

每个女孩都喜欢购物,dandelion也喜欢。现在,由于春节临近,她发现商店每天都在涨价。她喜欢一家叫做“memory”的商店。 现在她想知道每天价格变动后这家商店的价格等级。

输入

一行包含一个数字n(n <= 10000),代表商店的数量。
然后n行,每行包含一个字符串(长度小于31,并且仅包含小写字母和大写字母。)代表商店的名称。
然后一行包含一个数字m(1 <= m <= 50),代表天数。
然后,包含m个部份中,每个部份包含n行,每行包含一个数字s和一个字符串p,代表这一天,商店p的价格增加了s。

AC代码

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <map>

using namespace std;

int main()
{
    int n;
    while (cin >> n)
    {
    	//输入商店名
        string str;
        for(int i = 0;i < n;i++) cin >> str;
        
        //输入天数
        int m;
        cin >> m;
        
        map<string,int> shop;//map集合,用来存储变化的价格
        
        //增价及对应的字符串
        int p;
        string s;
        while (m--)
        {
            for (int i = 0;i < n;i++)
            {
            	//将每次增加的价格加到原价格上
                cin >> p >> s;
                shop[s] += p;
            }
            
            //ans指排名
            int ans = 1;
            map<string,int>::iterator it;
            for (it = shop.begin();it != shop.end();it++)
            {
            	//遍历集合,it->second表示当前迭代器指向的商店增价,shop["memory"]表示商店memory的增价
                if (it->second > shop["memory"]) ans++;
            }
            cout << ans << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值