POJ 2376 Cleaning Shifts (贪心算法)

原题链接

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.
Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T
  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
INPUT DETAILS:
There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.
OUTPUT DETAILS:
By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

单词
原题大意
  • 有N头奶牛,每头奶牛在一个专属时间段负责清洁工作。设计一个算法计算全面覆盖给定的时间段最少需要多少只奶牛
  • 如果不能覆盖给定的时间段则输出-1
题目翻译
分析
  • 假如第一头牛的工作时间是1 ~ 10,显然,最少只需要一头牛就可以覆盖所有的区间
  • 假如第一头牛的工作时间是1 ~ 2,第二头牛的工作时间是2 ~ 10,显然,最少只需要两头牛就可以覆盖所有的区间
  • 故先按每头奶牛负责的起始时间排序。然后顺序进行覆盖的计算处理。使用尽可能少的奶牛,尽可能用工作的终止时间靠后的牛即可
AC代码
#include <iostream>
#include <algorithm>
using namespace std;

struct Cow{
    int beg;
    int end;
}cows[25010];

bool cmp(Cow&a,Cow&b){
    if(a.beg!=b.beg) return a.beg<b.beg;
    return a.end>b.end;
}

int main() {
    std::cin.tie(0);std::ios::sync_with_stdio(false);

    int n,t;cin>>n>>t;
    for(int i=0;i<n;++i){
        cin>>cows[i].beg>>cows[i].end;    
    }
    sort(cows,cows+n,cmp);

    int end=0,new_end=0;
    int ans=0,i=0;
    while(end<t){
        // 尝试找到下一个最大的 end
        while(i<n&&cows[i].beg<=end+1){
            if(cows[i].end>new_end){
                new_end=cows[i].end;
            }
            ++i;
        }
        // 更新失败
        if(end==new_end){cout<<-1;return 0;}
        // 更新成功 
        end=new_end; 
        ++ans;
    }
    cout<<ans;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值