ACM: 模拟队列判定 poj 1426

                                                                   Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

 

Sample Input

2
6
19
0

Sample Output

  10

  100100100100100100

  111111111111111111


题意: 找出十进制n 的 m倍的数,但是这个数必须有0 和 1组成.

解题思路:
                    1. 一开始看有点像数论. 但是仔细想,不用那么复杂.
                    2. 数据的规模不大,n不超过200, 队列广搜.
                    3. 模拟队列判定就OK了!!

代码:

#include <cstdio>
#include <iostream>
using namespace std;
#define MAX 2000005

int n;
long long a[MAX];

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d",&n) != EOF && n != 0)
    {
        int cur = 0;
        int total = 0;
        a[cur] = 1;
        
        while(true)
        {
            if( a[cur] % n == 0 )
            {
                printf("%lld\n",a[cur]);
                break;
            }
            else
            {
                a[++total] = a[cur] * 10;
                a[++total] = a[cur] * 10 + 1;
                cur++;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值