ACM: 三维迷宫广搜最短路 poj 2251…

 

                                                                        Dungeon Master

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).

Trapped!

题意: 在地下城里面迷宫寻找出口,变成三维而已.

 

解题思路:

                1.队列广搜没什么好说.(STL_queue + bfs)

                2.输入是注意一层迷宫后面要有空行,每一行结束有空格.

 

代码:

 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
#define MAX 35
int dir[6][3] = {{0,0,1} , {0,1,0} , {0,0,-1} , {0,-1,0} , {1,0,0} , {-1,0,0}};

struct node
{
 int x , y , z;
 int dist;
};

char map[MAX][MAX][MAX];
int L , R , C;

bool visit[MAX][MAX][MAX];

int bfs(node start)
{
 queue<node> qu;
 memset(visit,false,sizeof(visit));
 qu.push(start);
 int result = 0;

 while( !qu.empty() )
 {
  node t = qu.front();
  qu.pop();

  if(map[t.z][t.x][t.y] == 'E')
  {
   result = t.dist;
  }
  for(int i = 0; i < 6; ++i)
  {
   node tt;
   tt.z = t.z + dir[i][0];
   tt.x = t.x + dir[i][1];
   tt.y = t.y + dir[i][2];
   tt.dist = t.dist + 1;
   if(tt.z >= 0 && tt.z < L && tt.x >= 0 && tt.x < R && tt.y >= 0 && tt.y < C && !visit[tt.z][tt.x][tt.y] && map[tt.z][tt.x][tt.y] != '#')
   {
    visit[tt.z][tt.x][tt.y] = true;
    qu.push(tt);
   }
  }
 }

 return result;
}

int main()
{
// freopen("input.txt","r",stdin);
 while(scanf("%d %d %d",&L,&R,&C) != EOF && L + R + C != 0)
 {
  node start;
  for(int k = 0; k < L; ++k)
  {
   for(int i = 0; i < R; ++i)
   {
    getchar();
    for(int j = 0; j < C; ++j)
    {
     scanf("%c",&map[k][i][j]);
     if(map[k][i][j] == 'S')
     {
      start.z = k;
      start.x = i;
      start.y = j;
      start.dist = 0;
     }
    }
   }
   getchar();
  }

  int result = 0;
  result = bfs(start);
  if(result != 0)
   printf("Escaped in %d minute(s).\n",result);
  else
   printf("Trapped!\n");
 }

 return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值